9/15/11
6:52 am

Forum Question: Calendar event won’t deleat

I have an event on my iPhone 3g which I can not deleat. The event does not appear on my mobile me calendar or my iMac calendar. Nor is the option available on my iPhone, when I go into the the event to try and edit the event.There is no edit option there.
When I uncheck my at home(mobile me)calendar, the event disappears!!
I am at a loss as to where I can deleat the event. the event is set to repeat on the same day every week.
Great site and love the videos.
—–
Jim

Comments: 5 Responses to “Calendar event won’t deleat”

    9/15/11 @ 6:56 am

    Hard to say, but I bet that you have multiple calendars and this event is on a calendar that is not synced with your Mac or MobileMe.
    You’ll have to play detective to get to the bottom of it.
    Try looking around in MobileMe first to see if it is another calendar there.
    If not, try looking around in your iPhone’s Cal interface.
    If you still can’t get the item to delete it, perhaps a visit to the Genius Bar so someone can look at it first-hand.

    TLA
    10/20/11 @ 3:52 pm

    I had the exact issue and finally fixed it. Here you go:

    Change the Sync settings for your calendars:

    Tap Settings and select Mail, Contacts, Calendars.
    Scroll down to the bottom.
    Under Sync, if it’s set to All Events, set to a specific duration. If it’s set to a specific duration, set to All Events.
    Wait several minutes and try syncing again.

    Turn Calendar syncing off and back on:

    Tap Settings > Mail, Contacts, Calendars > your MobileMe account.
    Tap the Calendar slider off. Choose to delete data only if your data exists at me.com. Otherwise choose Keep Data.
    Wait a few minutes before turning the Calendar slider back on.

      SRN
      9/5/12 @ 10:47 pm

      TLA that worked for me

      CharlyMcWire
      11/15/12 @ 9:24 am

      Thank You. Worked fine.

    Heather
    12/2/12 @ 11:07 pm

    Thank you! I just substituted “iCloud” for “mobile me” and it worked.

Comments Closed.