12/3/16
8:11 pm

Forum Question: How Do I Get Safari To Open On Secondary Display?

I’m putting together a Keynote presentation. I run it from my primary display in Presenter view. The slides present on the secondary display. One of the slides has a link in it to a webpage. When I click on the link, Safari opens on my primary display, where my viewers can’t see it. I tried dragging the Safari window to the secondary display, but it wouldn’t quite go all the way over, and the link still opened on my primary display. How do I get the link to open on my secondary display so my audience can view the site?
—–
Cameron

Comments: 2 Responses to “How Do I Get Safari To Open On Secondary Display?”

    12/3/16 @ 8:11 pm

    You’ll have to experiment to get it right. I would start by trying to switch displays before you start the presentation: make the secondary the primary and the primary the secondary. Then when you start the presentation, switch those to match. See if that works.
    Or, keep things as they are by open Safari before the presentation starts, move it to the display you want, and see if it then works like you want.

    Cameron Price
    12/4/16 @ 3:46 am

    So I’ve played around with it some more. Turns out I had to uncheck “Displays have separate Spaces” in the Mission Control section of System Preferences, I could then drag Safari to the secondary display, and it would stay there. I generally leave it checked, because split screen doesn’t work when it’s unchecked.

Comments Closed.