11/5/11
4:45 pm

Forum Question: How Do I Send iCloud Email Using Another Email Address?

I’m trying to switch from Gmail to Apple Mail and iCloud.
I’ve forwarded my work email to iCloud.
In Gmail I have the option “Send mail as”, where I can specify my work e-mail address for outgoing mail and all outgoing mail is still kept by Gmail.
Can I do that with Apple Mail and have all outgoing mail kept in iCloud?
—–
Glenn Downing

Comments: 6 Responses to “How Do I Send iCloud Email Using Another Email Address?”

    11/5/11 @ 5:15 pm

    That was a feature of MobileMe email, but it does not appear to be a feature of iCloud. Looks like you can only send as the actual email address you are using.

    Glenn Downing
    11/5/11 @ 5:38 pm

    Figured it out!

    Just had to set up the outgoing mail server from work.

    Thanks.

      11/5/11 @ 6:03 pm

      So, it sounds like you are not sending iCloud email at all. iCloud email would be @me.com email that goes through Apple servers. If you are using your work server, then you are sending email through your work SMTP server and not iCloud. You are just using the Mail app on your Mac as an email client.

    Glenn Downing
    11/6/11 @ 12:29 pm

    It seems to be a mix to those two ideas.

    I only have an iCloud account in Mail. I have not added a work account.

    But in the one iCloud account I changed my address from …@me.com to my work address.

    I then added the work SMTP server to the Outgoing Mail Server list.

    When I send email with this configuration the receiver gets it as if I sent it from work, and I see the sent message in iCloud’s Sent folder.

    I can then see that sent message on my iPhone even though I sent the message from my iMac.

    But… something interesting has happened.

    If I then go to System Preferences -> Mail, Contacts & Calendars I see two entries: iCloud (Contacts and 4 more…) and iCloud (Mail).

    If I then click on ICloud (Mail) I see that it’s MobileMe!!!

    I didn’t do any of that. It just happens automatically as a function of me changing the email address and SMTP in Mail’s Preferences. And I’ve done this several times both on my iMac and MacBook and the same thing happens repeatedly and consistently.

    So, perhaps this is some kind of Apple workaround for now, and it will eventually turn into a cleaner iCloud feature?

    Hope this is helpful to your other readers.

      Jeremy V
      2/20/12 @ 6:07 pm

      I am trying to figure out the same thing. You said “But in the one iCloud account I changed my address from …@me.com to my work address.” How exactly did you do that? I want to send from my iPad so that people receive it like it came from my work address.

        Maxim Chicheyev
        5/7/12 @ 3:43 am

        Just add another SMTP server to your SMTP server’s list in your mail app.

Comments Closed.