10/2/12
6:07 am

Forum Question: How To Sync Calendar Alarms Over iCloud?

We have shared our calendars between family members.
But somehow the alerts are not synched.
For instance I created a reoccurring event for my daughter in her shared-iCloud calendar (weekly dance course). And I added an alert 35 minutes before the start of the event. I created on my Mac so my iCloud account was active. But it was configured that I’m allowed to add events to her calendar.
I can get the alerts on my Mac and on my iPhone. But the calendar is also shared to my wife and on her Mac and iPhone there are no alerts coupled with the event.
Even on the Mac of my daughter (who should be the owner of the calendar) there are no alerts attached to the event.
So it looks that when I create an event, that the alerts are stripped when send over to the others that share this calendar.
On the Mac you can set per shared calendar whether you want the alerts to happen or not. But I cannot find any setting that will tell that these alerts are not synched to iCloud at all.
When I log in on www.iCloud.com I get following result:
My account: The alerts can be viewed.
Wife account: No alert in the events.
Daughter: No alerts in the events.
So it looks that the alerts to events cannot be shared. Anybody knows how to set this up?
—–
Dirk Awouters

Comments: 5 Responses to “How To Sync Calendar Alarms Over iCloud?”

    10/2/12 @ 6:41 am

    Try control+clicking on the calendar on the left side of the Calendar app. Get Info on those shared calendars. There is an option for “Ignore Alerts.” See if that is checked on your wife or daughter’s Calendar app.
    Try control+clicking on each calendar in the Calendar app on each machine. Check every option and see if you can figure out what is set wrong. Or, simply have them unsubscribe and the re-subscribe to the calendar and see if maybe an option was missed when they first subscribed.

    Dirk Awouters
    10/2/12 @ 6:59 am

    Checked on all 3 the option “ignore alerts” and it is not checked on any of the 3 Macs.

    I removed the sharing completely. Saw that the entries where removed on my Mac. Then shared again. During sharing you can only set the apple-id of the other person you share with, no settings whether alerts are send over or not.

    When accepting the share, there are no options you can select. Afterwards the control-click revealed that the “ignore alerts” option was not selected. The alerts themselves are not available in the shares.

    Dirk Awouters
    10/2/12 @ 7:19 am

    I noticed now that on my iPhone all these events from my daughter have a 15 minute reminder set. While in the original calendar on her Mac it was set at 25 minutes.

    This is because I have a default 15 minute reminder set on my iPhone for new events. But I toughed this was new events I entered on the phone.

    Anyway searching the net reveals to me that others have the problem in the other way around. They do get the alerts and don’t find a way to get rid of them.

      John M. Hammer
      10/2/12 @ 9:36 am

      Events shared from another person will have the default alert time set when the event is synced over. The recipient can change the alert time for each event “by hand” as they come in, or can change their default alert time.
      I agree that this is silly behavior, and hopefully Apple will do something about it. I’ve registered my suggestion here; perhaps you will as well.
      https://ssl.apple.com/support/feedback/

        Ben
        2/18/13 @ 4:38 am

        Yep, you appear to be right. The alert times you enter are not sync via iCloud, and there default alert time of the device, at the other end, is what will be used.

        If no alert is default is entered then now alert will happen unless that person edits the event and adds an alert(s).

        I have posted my suggestion to spe to change this as well via your link above.

Comments Closed.