7/27/11
3:39 am

Forum Question: MAIL duplicates all send and receive mail

Since I upgrade to LION, the MAIL application does duplicate all me emails in “inbox” and “sent”. I also have tried to enable the option in settings: “remove copy from server after retrieving a message”, but no help. Thank you for your help!
—–
Codrut Moreanu

Comments: 12 Responses to “MAIL duplicates all send and receive mail”

    7/27/11 @ 7:13 am

    Sounds like you are using POP email? What system are you using? (Gmail, Yahoo, MobileMe, Exchange, something corporate, etc)
    If you are using POP, can you switch to IMAP. Many email systems support either one, but IMAP would work much better.

      Codrut Moreanu
      7/27/11 @ 2:21 pm

      I use two: one personal – google mail(IMAP); and one for work(a company server: POP). The same settings i had on snow leopard without a problem. Now all mails are duplicates 2 or 3 times…
      Thank you!

        7/27/11 @ 2:54 pm

        Sounds like you need to review your settings for each account carefully. Maybe some first-hand help (Apple Store).

    Michael
    7/27/11 @ 10:07 pm

    I just fixed this. Go to your Gmail setting in the browser and click the labels tab and uncheck the “show in IMAP” for the “important” label. that will fix it

    Michael
    7/27/11 @ 10:12 pm

    and you may want to try unchecking the “all mail” label

      Codrut Moreanu
      7/28/11 @ 10:36 am

      Michael, thank you for your help. I have tried both your advices but the problems remain. I dont know what to do…

    Michael
    7/28/11 @ 8:17 pm

    really? email Adam Christian form the MacCast. He was the one who told me what to do because he was having the same problem. Worked for me and him and plus he will explain in detail whats going on and maybe help you understand more:) Good Luck

    Michael
    7/28/11 @ 10:57 pm

    May sound like a stupid question, but did you quit and relaunch mail app after making changes?

      Codrut Moreanu
      7/29/11 @ 12:26 am

      Yes, sure. Thank you again for your help.

    Adam Christianson
    7/29/11 @ 9:11 am

    Codrut did email me, but I wanted to share my response here also in case it helps someone else.
    ————–
    Do you have you’re mail set up to send you copies of messages (CC) that you send? It sounds like you could from your description. If that is the case then it would be normal to have a “duplicate” since you’d have the copy in the Sent IMAP folder and the one in your INBOX. The change it Lion is just that now with Conversations set to group those together you are made more aware of the presence of the duplicate. Another cause may be on the GMail side. Do you have Gmail rules (filters) that auto apply labels to your mail? I think part of the issue there is that when Gmail applies a “label” it really seems to just create a copy in a different IMAP folder. For example, I have a rule that when it sees an email with a specific subject it applies a “label”, but it also leaves that message in the INBOX. In those cases I end up with “duplicates” in Mail. I have had to go back into my GMail filters and select the “Skip the INBOX” option on the second screen (https://skitch.com/adam/fct2q/skip-inbox). That way I don’t end up with duplicate emails for those messages. Also. as was mentioned on that forum, make sure you go into the Label settings in GMail and turn off ‘Show in IMAP’ for the ‘All Mail’ label (https://skitch.com/adam/fct2i/showinimap).

    Hope this information helps.

    Michael
    7/29/11 @ 7:45 pm

    Thanks Adam:)

    Michael
    7/29/11 @ 7:50 pm

    …And sorry I spelled your name wrong:)

Comments Closed.