2/24/10
10:00 am

Forum Question: Problem with USB thumb drive

I have an 8gb thumb drive that I wanted to use to transfer video files from my mac to a pc. I’ve formatted the thumb drive with disk utility (FAT), and put the files onto it. When I plug it into the pc, it says the drive needs to be formatted. And if I try and format it on the pc, it tells me it’s only 200 MB. Any idea why I might be having so much trouble? I thought the whole idea of using a thumb drive was to make it easy to transfer files between computers.

Thanks

— Fulvio

Comments: 7 Responses to “Problem with USB thumb drive”

    2/24/10 @ 10:02 am

    Sounds like an issue with the drive. I’d try to format it on another PC and see what happens. It could also be an issue with the PC. If the Mac formats it as FAT32 and it works fine with all 8GB, then everything seems to be fine on that side. Maybe the PC is having an issue with USB or its file system? Is it an old PC?

    Jason
    2/24/10 @ 10:15 am

    I have sort of the same problem…only mine is between a MacBook and a Mac Mini. The Mac Mini rarely sees the thumb drive…regardless of which rear USB port I put it in….

    Fulvio
    2/24/10 @ 11:32 am

    The pc is about 5 years old. When I use disk utility it doesn’t give me the option to format FAT32. Could that be a problem?

    I just don’t understand why it shows up as 8GB on the Mac and only 200 mb on the pc.

    I’m just finding this all frustrating……

    Thanks

      2/24/10 @ 1:07 pm

      It should give you the option for FAT32 — that should always be there. Maybe you are not selecting the right items in Disk Utility? As for the 200MB limit on the PC, it must either be a problem with the thumb drive or the PC. Maybe you just got a bad thumb drive. I’ve used dozens and never had any issue like this.

    Ross Craig
    3/10/10 @ 4:55 am

    I had this issue, the iMac could read and write to the thumb drive without an issue. My Windows PC stopped letting me write to it and it would only let me format it 20 the 200mb. I email HP and they sent me a replacement free of charge. I still use the other one holding files for my iMac only.

    Mark Morsi
    9/19/10 @ 10:35 am

    I know this is old, but the problem doesn’t seem to have been probably answered.

    The 200 MB limit is because the drive Partition table is set to GUID, Windows cant access this partiontable because it propritary, it therefore sees the disk as only having 200 MB of fysical space. Because the GUID partition contains boot information it is normally invissible on a newer mac.

    The fix is really simple in ‘disk utility’ choose the device and then the ‘partition’ tab. Selecting ‘Volume Scheme’ choose the desired amount of voloumes and then click options under the visual layout of the partion. Here you need to choose ‘Master Boot Record’ indstead of ‘GUID Partition Table’.

    This should fix your problem and make the whole disk avalible to the PC.

    Alex
    10/17/10 @ 8:29 pm

    Mark Morsi- THANK YOU!
    That is the only right answer I have been able to find. I did that and it worked! Thanks again!

Comments Closed.