6/11/12
11:54 pm

Forum Question: Sharing & Permissions Settings When Using File Vault

I have a Mac Pro with my OS and apps on a SSD while I store my data on a HDD in another bay in the Mac Pro. I am running Lion, and I recently (a couple months ago) turned on FileVault. I believe by doing that it changed some of the sharing & permission settings in my data HDD because now my other user accounts which are admins can’t access some of the folders in the HDD. Am I correct, turning on FileVault changed Sharing & Permissions on the data HDD? For example, I have my user account set to download files from Safari to a folder in the data HDD, but my other user accounts with admin privileges can’t access this download folder. I am pretty sure they could before.
Looking at the folders on the data HDD via Get Info my user name is on the top of the list, so I assume I “own” it. What’s the best way to set Sharing & Permissions, so that my other user accounts can access the data HDD? There’s a “staff” icon, or I can individually select users, or I can use the “admin” selection, and finally there’s “everyone” selection.
—–
Royce

Comments: 3 Responses to “Sharing & Permissions Settings When Using File Vault”

    6/12/12 @ 8:16 am

    Try getting info on the drive. Then look for the “ignore permissions on this drive” checkbox. Try that. Not sure if it will work, though. If File Vault has encrypted your second drive, then only that user account can access it.
    I’ve never tried to use File Vault with multiple drives like that before. Usually you use it with laptops — devices that can easily fall into someone else’s hands.
    The whole idea of File Vault is to encrypt the data on your drive. But it sounds like you want it to just work on your first drive which only has your OS and apps. Why encrypt that? Your “stuff” is on the second drive, and you want to share that.
    So why use File Vault at all?

    Royce
    6/12/12 @ 1:33 pm

    The data HDD should NOT be encrypted as I turned it on only for the SSD with Lion & apps. In preferences in Safari I changed my downloads to the data HDD. Maybe because of that when I turned on FileVault it changed Sharing & Permissions. I also use SuperDuper to create bootable backup of my system and before cloning it “fixes” Sharing & Permissions, maybe SuperDuper changed the settings.

    I’ll go into Get Info at the top level of the data HDD and try what you say. If that doesn’t work should I’ll need to go into the folders and use Get Info to change settings. Should I use “admin” or “staff” users, maybe the individual user names? Good thing there are only a few folders in the data HDD … Movies, Documents, etc.

    Btw, what is a good way to encrypt my data HDD, if I choose to do that?

      6/12/12 @ 2:20 pm

      Ah, yes. Using SuperDuper will change that “ignore permission on this drive” setting. Just turn that back on. I have to do that all the time.

Comments Closed.