MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Assign a Keyboard Shortcut To a Command With an Apostrophe?

I want to add a custom keyboard shortcut for the « Love » command in the Music App. I know how to assign a custom keyboard shortcut to any command in a particular app. However, I’m unable to assign a shortcut to the « Love » command in the Music App in French. I did some tests and it seems like the apostrophe in the French command « J’aime » might be the problem. I can easily add a shortcut when the app is in English but the shortcut disappears when I go back to French. I tried assigning a shortcut to the “Play next” command while in French “Suivant”, and it works like expected. Other commands containing an apostrophe (Format d’impression, Je n’aime pas) don’t work either.
—–
Jean-Claude

Comments: 2 Responses to “How Do I Assign a Keyboard Shortcut To a Command With an Apostrophe?”

    2 weeks ago

    That’s a good question and I’m not sure I can figure out a solution for you. Since my Mac is set to English, I don’t see J’aime as the menu command, but Love. So I can’t experiment.

    I would simply try everything. Try the straight apostrophe (‘), the curved one in either direction (‘ Option+] and ’ Shift+Option+] on the US keyboard. Try the back-tick character (`). Maybe try just leaving it out completely.

    My money is on Option+] though. See if that works.

    Jean-Claude
    2 weeks ago

    This works: option+] on the US keyboard. Thanks! By the way, you could easily experiment with other language commands by switching system language in System Preferences. My system is usually in French but I often switch it temporarily to English when I need to know how certain commands or warning messages are worded, so I can search the web for solutions to problems. Thanks again for your help!

Leave a New Comment Related to "How Do I Assign a Keyboard Shortcut To a Command With an Apostrophe?"

:
:
:
0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)