MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Control Which Screen the Command-Tab Application Chooser Appears On?

I am working in an application on my iMac, Safari in this case typing this question.

My iMac has a second screen plugged in.

When I use Command-Tab to open the application switcher the application switcher appears on the other screen, not my iMac screen which I am actually looking at. The chosen application then appears on my iMac.

Not a huge issue just frustrating and it feels like something I should be able to control.

Thank you for your help

—–
Ian

Comments: 5 Responses to “How Do I Control Which Screen the Command-Tab Application Chooser Appears On?”

    11 months ago

    I believe it always appears on your main screen. You can set your main screen in System Preferences, Displays, Arrangement. Drag the white rectangle at the top of the current main screen to another screen. This represents the menu bar.

    Ian
    11 months ago

    Thanks Gary. When I opened Displays the white rectangle was at the top of my iMac screen. I moved it to the other screen and the application chooser then opens on the other screen, when I move the white rectangle back it follows. Now it is working as expected. The next time it doesn’t I will check Arrangements to see where the white rectangle is.

    I am curious about the menu bar though, as I have one on both screens.

    Thank you for your help.

    11 months ago

    Ian: I think you see the men bar on all screens when you have “Displays have separate Spaces” in Mission Control preferences.

    Ian
    10 months ago

    Gary, hi, the Command-Tab Application Chooser has just appeared on my second monitor yet when I check the position of the white rectangle I find that it is above my iMac screen, I wondered if you had any further ideas as to how I can get this under control? Safari is in full-screen on my iMac yet when I use Command-Tab the Application Chooser appears on my additional monitor.

    Thank you for any further ideas you may have.

    10 months ago

    Ian: In System Preferences, Dock, do you have “Automatically hide and show the Dock” turned on? If so, I believe the app switcher shows up on the display where e the Dock last appeared. Try having the Dock appear on different screens by moving the cursor down there and see if that is true.

Comments Closed.