9/16/10
9:23 pm

Forum Question: Can iMovie duplicate audio track to create a stereo effect?

In iMovie HD, is it possible to create a L and R audio to make the DVD play in stereo? I guess I would need to extract the audio and then create two duplicate audio tracks by coping the extracted one and pasting the new one into a new track. But is there a way to assign one track to be L and the other to be R so that I get the stereo result?

— Matt

Comments: 18 Responses to “Can iMovie duplicate audio track to create a stereo effect?”

    9/16/10 @ 9:25 pm

    By iMovie HD, do you mean iMovie in iLife 06? (The old old version?) I haven’t used it in years, but I assume that like iMovie 09, the way to do it is not in iMovie, but in GarageBand. It acts as the ultimate sound editor for videos.
    See this video: http://macmost.com/editing-a-video-soundtrack-in-garageband.html

      Matt
      9/17/10 @ 10:18 am

      So, in Garageband, would I extract the audio and then create two duplicate audio tracks by coping the extracted one and pasting the new one into a new track? Then make one L and one R?

        9/17/10 @ 10:22 am

        It depends on what you are trying to do. If the tracks are the same, then there’s no point in putting the same track in the left and right channels. You might as well just keep the audio as mono. But maybe that’s not what you are trying to do. What is the desired result. Give me an example.

    Matt
    9/17/10 @ 11:27 am

    Well, just purchased a Canon GL-2. I does not have an XLR input so I have a MA-300 Adapter to use. However, it has a L and R XLR input. If I use an XLR cable from the receiver of my wireless mic to the, let’s say L or R. Then the sound will only come out of one speaker when my student listens to his/her lesson.

    So, I’m assuming the work in Garageband would make it to where the student could listen in stereo (both speakers).

    Or, would it be simpler (and would it do the same thing – only on the front end) to use a Y cable that goes from teh receiver and then branches into 2 male ends that would go into the MA-300 adapter?

      9/17/10 @ 11:49 am

      Ah, I see. So you really have mono sound, not stereo. Just a glitch that puts it in one track instead of both. So no need to do anything while editing or use GarageBand. When you export, do a custom QuickTime export and set the audio to mono instead of stereo.

        Robert Marcos
        8/12/11 @ 6:26 pm

        OMG thank you Gary for this advice. I’d spent two days trying to copy the one-sided audio from my lapel mic onto both channels of my iMovie video. Your advice about selecting “mono” during the Quicktime solved the problem. Apparently the mini-plug on my lapel mic needs to be stereo but isn’t. So my Canon 60D only records one channel of audio.

    Matt
    9/17/10 @ 12:09 pm

    And I do this even if my ultimate goal is so that the student hears the audio for teh video out of both speakers?

      9/17/10 @ 12:24 pm

      Right. What it sounds like is your camera is giving you stereo files — one channel with all of the audio and the other with nothing. iMovie doesn’t know that that isn’t what you intended. So it keeps the movie in “stereo” with both channels. But exporting in mono, you have a mono movie that plays one channel of audio out of both speakers.
      Try it.

    Matt
    9/17/10 @ 12:29 pm

    Okay, I will try it. Thanks for your help! Love your videos!

    And if I wanted stereo, would I just use a y-cable as mentioned above?

      9/17/10 @ 12:34 pm

      It sounds like your mic is a mono one (many are, of course — it is only recording sound from one point). So splitting the one track with an adapter into two would work, but you are just duplicating the same mono track. Not stereo at all.
      You could get a stereo mic, if you really want stereo. Or, just stick with mono. It is up to you.

    Fiona
    4/1/11 @ 2:59 pm

    I have a similar problem. We screwed up the recording with the video camera and had one channel set to XLR mic and the other (right) channel set to INT/EXT mic. All the audio comes from the right channel and is technically recorded in Stereo. Does anybody know if there’s a way to fix it? Will it be best to make this stereo track mono and then duplicate it somehow? Thanks in advance!

      4/1/11 @ 3:39 pm

      No point duplicating a mono track. Just work with it as-is and then when you export it, export it with custom settings as mono audio for the entire video.

    Cecybrizz
    9/2/11 @ 10:45 am

    Hello there, thank you for the tip. I was also having a hard time trying to figure out how to make the sound come out of both speakers. Thank you very much, However I have a question. what about if you want to export the movie as HD for a better quality. I usually do >share >export movie >HD1080p then I upload it into youtube or I make a copy of the video.
    Instead of exporting it as a quicktime movie is there a way you can you export it as Hd and still fix the sound? or do you have to exported as a quicktime? always.

      9/2/11 @ 11:00 am

      Just export it as 1080p with a mono soundtrack. So when you choose your QuickTime settings, set the video to 1920×1080.

    Peter
    10/27/11 @ 6:12 pm

    same problem but want to send the iMovie project to iDVD. Any way to get the single audio track to play through both speakers, other than duplicating the track?
    Thanks

    P

      10/27/11 @ 6:43 pm

      Export as a QuickTime movie with mono instead of stereo. Then import that file into iDVD.

        John
        1/19/12 @ 8:00 pm

        Gary thank you for your great tip however, the problem I think Cecybrizz and I are having is that Quick Time exports movies(even in 1080) with really bad quality. The quality is still bad when I export the video in MP4 > Options > Image Size: 1920×1080.

        After the export, the sound does have both channel lined up but the image quality is sloppy. Is their a way to have the video in stereo and keep an HD quality?

          1/19/12 @ 8:35 pm

          I’m not quite sure which export options you are choosing. There are thousands of variations. How many have you tried? Because if you are getting bad quality, then it just shows that the options you are choosing aren’t the quality you want.
          If you really want to use the Export Using QuickTime menu choice, then I suggest selecting “Movie To QuickTime Movie” option (Not “MPEG-4”). Then click Options and choose h264. Or, use the norma “Export Movie” option and choose the highest preset.

Comments Closed.