10/20/10
2:57 pm

Forum Question: Disable Macbook Pro Microphone

I have a 2010 mid-year 17″ MacBook Pro. I want to disable, or turn off the internal microphone. How do I do this? I tired to turn it off in “System Preferences” but that doesn’t work. Any information would be greatly appreciated.
Thank you.
—–
Bob in Nebraska

Comments: 10 Responses to “Disable Macbook Pro Microphone”

    10/20/10 @ 3:02 pm

    The microphone isn’t “enabled” or “disabled” — you either use it or not. So I’m not sure what you are trying to do. For instance, if you want to record your voice into an audio application, you use it. If you don’t want to record your voice into an audio application, then you wouldn’t be using an application like that.
    You can go into System Preferences, Sound, Input and then turn the input level down to nothing. Is that what you tried? If so, then how do you know “that doesn’t work” — what did you try to do that made you think the mic was still allowing you to record?
    Some sound applications have their own independent sound input level controls — but if your goal is to not use the microphone, I’m not sure why you would be using the application to being with.

      Bob P.
      10/20/10 @ 3:15 pm

      Hi Gary,

      Regarding what I tried, yes I went into Sound, Input, and turned the input level all the way down. Yet when I speak, my voice level still appears on the little “Input Level” graph underneath the “Input Volume” sliding graph.

      What I’m trying to do is stream a video of myself but I want to use an external microphone instead of the built in microphone. Perhaps the internal microphone disables automatically when an external mic is plugged in? I haven’t tried this but it just came to mind.

      Thank you.

        10/20/10 @ 3:17 pm

        When you plug in the external Mic, you can then go to that same sound preferences panel and switch input devices. So you get to choose which mic to use. Some recording/streaming programs let you do that right there, instead of having to go to the system prefs.

          stan zisk
          5/1/11 @ 11:14 pm

          My problem is that I want to record from the input jack on my MacBook Pro without having ambient sound picked up by the built-in microphone at the sametime. But even when I switch the sound input in System Preferences to “line in – Audio line in port”, the internal mike is still live and is still picking up the washing machine noises, etc. mixed in together with the audio I am feeding in to the input jack. Can the internal mike be turned off and still have the rest of the audio system work?

            5/2/11 @ 6:43 am

            What software are you using to record? Perhaps it has its own audio input preferences that it uses, not the System Preferences. If you select to have another source for audio input, then it will not use the internal microphone.

      Rob L
      11/13/11 @ 11:56 am

      He asked how to turn it off–since the mic sound level indicator clearly indicates that it is detecting and processing sound the whole time the machine is on. How about an answer–can it be turned off, or is the microphone on at all times regardless of what the user wants? And if so, why?

        11/13/11 @ 12:14 pm

        I don’t think it is on at all. It os only on if you are recording or if you have a sound level indicator on the screen. If neither thing is happening, it wouldn’t be processing anything.

        Louis Letienne
        8/3/12 @ 8:30 am

        Hi!
        To disable the MacBook Pro’s mic (it works for my later 2009 17″), go to Applications, Utilities, Audio Midi, and click in the MUTE boxes.
        It should do the trick!
        Bye!

          8/3/12 @ 8:43 am

          Or, just go to System Preferences, Sound, Input and turn the volume down. But individual apps can have their own individual settings for the Mic.

    Bob in Nebraska
    10/20/10 @ 6:51 pm

    Gary,
    Thank you!! It works like a charm and sounds great.
    I’m a Mac newbie and still learning so I appreciate your help. I wish I would’ve switched from PC to Mac years ago but better late than never.
    Thanks again!
    Bob in Nebraska

Comments Closed.