8/27/11
8:28 pm

Forum Question: Force OS/X to mirror screens without system preferences

I have been given an iMac with a cracked screen. The old owner tried to swap out the internal drive and it broke when trying to open the case.
With the break, you can not see anything on the display, just a flash of light.
I have added a vga adapter and hoping to get the machine to mirror the main display to an external and use the machine with my kids. On boot, I can see the snow leopard image on the external display, and it is booting in the default extended display mode. Since the main screen is unreadable, I can’t use system preferences to set the display options to mirrored.
Any ideas on steps to force this mode every time it boots?
—–
Ian P.

Comments: 3 Responses to “Force OS/X to mirror screens without system preferences”

    8/27/11 @ 8:47 pm

    Try Command+F1. Or, Command+FN+F1.
    On many MacBook Pros this will turn on and off mirroring. It might work on your iMac too.

      Braincage
      2/11/13 @ 1:42 am

      Thanks, that worked a treat!

    Ian P
    8/28/11 @ 7:36 pm

    Gary,

    Thanks for the quick response.

    Wanted to share the results of the suggestions. Unfortunately those commands did not work on the iMac.

    I did go a few steps and did get it to work.

    I have another imac that I leveraged to get a solution.

    I booted both. I logged in as admin on both machines. I got iMac (broken) to boot up in target disk mode and connected to iMac (working).

    Before rebooting iMac (working), I disconnected the VGA adapter and plugged into iMac(working) and set to reboot from the broken in target disk mode.

    Then I was able to operate the broken machine from the working.

    I downloaded dejamenu (to do menu bar on both windows if needed in the futre) and set dejamenu as a start up app in the user accounts.

    I set up mirror displays in the system preferences.

    Then shut down the machines.

    Reconnected the VGA adapter to iMac (Broken) and turned it back on. It is working great.

    Thanks for the podcast!
    Ian

Comments Closed.