7/26/11
11:06 pm

Forum Question: Lion : iMac does not automatically connect to my WIFI network !

Gary, in Lion my iMac does not automatically connect to my WIFI network !
The Wifi bars remain Grey and it connects only when I click the Wifi Bars and choose my Wifi Network Name.
Earlier it would connect automatically !
I tired checking and unchecking the “Ask to join networks” option in my network system preferences !
Thanks !
Cy !
—–
cyrus Dubash

Comments: 19 Responses to “Lion : iMac does not automatically connect to my WIFI network !”

    7/27/11 @ 7:22 am

    Don’t know why it would be doing that, sorry. Hard to troubleshoot those things. Did you try playing around with the “Preferred Networks” settings. System Preferences, Network, select your wi-fi connection, Advanced Button, click on the Wi-Fi pane.

    Michael
    7/27/11 @ 10:15 pm

    Try going to System Preferences/Network/Advance and deleting all your Prefered Networks and rebuild them

    Russell
    10/5/11 @ 7:15 pm

    I am seeing the same thing with Lion.

    In Snow Leopard my iMac connected automatically every time to my network. My network is the only one in my list, but there are 10 others nearby it can see. No problem before.

    Now with Lion it makes me select my network manually every time and then takes a few seconds. Very annoying to have to do this every time I step away for a few minutes.

    I have heard this may be a bug… any idea Gary? others having this issue?

      10/5/11 @ 7:17 pm

      Did you try Michael’s idea? Also, try deleting the network from your preferred networks?

    Russell
    10/5/11 @ 7:24 pm

    I tried that a while ago, but will try again to make sure.

    I also found this:
    http://osxdaily.com/2011/07/22/wifi-dropping-in-os-x-lion-fixes/

    I just reset the router to see if that helps…

    Russell
    10/9/11 @ 7:28 pm

    resetting the router did indeed help. after a few days, my wifi is dropping only occasionally now. for experimentation purposes I’m going to wait a few more days before I delete and re-add the network info so I will know for sure what is/was the culprit…

    Bryon
    10/19/11 @ 4:43 am

    My mbp wasn’t automatically connecting to my preferred wifi network either. I corrected the problem by going to System Preferences -> Wifi -> Advanced and I removed my network by highlighting it and clicking the minus “-” sign. Notice that the network probably says the network is ‘Unprotected’, at least mine did despite it being saved with the passkey?? Add your network again with the passkey and ask the system to remember the passkey on the key chain. Drag the network to the top of the network list if desired. These actions corrected the problem for me. I use a Cisco Valet Plus, by the way.

      Joni
      2/2/13 @ 3:24 pm

      I deleted, then re-entered my wireless’ name in the area for listing networks, then re-entered the name and the password type/password.

      I re-booted the iMac and YaY! It turned on WITH all bands dark!

      This worked for us ~
      THANKS!

        Sea shell
        2/15/13 @ 12:39 pm

        I tried this and it worked for me too…am delighted thank you :)

    Nick
    1/9/12 @ 1:16 pm

    Ok guys thanks for helping me find the problem, the problem is not Lion the problem is your settings, go to system preferences, then Network, Uncheck where it says ask me to join new networks. Hope That Works

    SERGIO OSORIO
    1/24/12 @ 2:34 pm

    I had the same problem, I brought my Imac to the apple store to be looked by a genius, they kept it for a day and they said it was just fine. they did not do anything to it.
    I call apple care and i was out of the 90 days free support.
    so, I did what bryon did and it worked.
    now its fine.

    Marko
    3/1/12 @ 9:19 am

    I had the same problem. I just received an automatic update from Apple:
    “This update resolves an issue that may cause an iMac to not automatically connect to a known Wi-Fi network after waking from sleep.

    It is recommended for all iMac (Late 2009 or newer) users running 10.7.3.”

    Harry
    6/2/12 @ 8:18 pm

    I found that Gary and Michael’s suggestion solved this problem for me (but it’s very frustrating that Mac still has not fixed this problem). Here’s what I did: go to System Preferences/Network/Advance and delete all your Preferred Networks by clicking on the minus sign. Then hit the plus sign to “Add a Wi-fi Network profile” and click on “Choose a network …” to find the wi-fi service. The Mac found my wi-fi service (and remembered my passkey). Interestingly, it now records the security as “WPA/WPA2 Personal”. I think the security was either blank or WEP previously (I read somewhere else that this might have been the source of the problem). thanks all for the comments – helped me solve a tedious, frustrating little problem.

      omwahabi
      7/13/12 @ 11:03 am

      thanks Harry, it worked

      drummed
      12/31/12 @ 11:56 am

      Thank you! This problem has been annoying and your solution worked for me!

    Irene King
    6/16/12 @ 11:03 am

    I have to disagree with a couple of people here who stated that it *isn’t* a problem with Lion. OF COURSE it’s a problem with Lion! I don’t remember seeing in the documentation that it was necessary to reconfigure one’s WiFi connection in order for it to work in Lion! My computer that’s still running Snow Leopard (1st Gen all-in-one iMac) has never had any connection issues, only my 2010 iMac and only when I upgraded to Lion. I did as others have – deleted the networks and re-added my own. We’ll see if it can longer than 15min. without dropping.

    Shayne
    7/31/12 @ 2:43 am

    I have this exact problem with my brand new iMac! I’ve spent the last hour on the phone with AppleCare, who were dumbfounded. They eventually emailed me the update Marko mentioned above (http://support.apple.com/kb/DL1501) but it’s for OS X 10.7.3, not 10.7.4, so it’s useless :(

    Bruce
    8/1/12 @ 12:13 pm

    Bryan’s suggestion worked perfectly. Just remember to turn off an on the Wifi to “solidify” the changes. I was amazed at the hundred or se old wireless networks that were in there.

    Mohamed
    10/29/12 @ 4:39 pm

    You might want to try this – it worked for me.

    The idea is to make sure that the security method matches that of the wifi.

    * Go to Network Preferences > advanced > Wi-Fi and delete your wifi by selecting it and pressing the “-” sign.
    * Press the “+” to add a new wifi.
    * Type the name of your wifi (do it manually, please)
    Now the most important step:
    * Choose the security method that matches your wifi settings (Check your wifi settings if not sure).
    * Type your password (if applicable)
    * Press OK, OK, Apply and you are done.

    I hope this helps someone out there.

Comments Closed.