8/2/11
11:55 pm

Forum Question: Push mail Gmail in lion’s apple mail

I want to setup my gmail in the Lion’s  apple mail. 
On my iPhone I use the Microsoft exchange setting with server address as m.google.com and it looks book the key with email is being forced to my phone.
I tried setting setting it up same way on my iMac. But it does not seem to work
I can only use the gmail option which does not have push mail.
Option ! In preferences I can only use the minimum 1 minute setting to check for new emails. 
Is there a way to push my emails on the iMac? 
—–
Cyrus Dubash

Comments: 12 Responses to “Push mail Gmail in lion’s apple mail”

    8/3/11 @ 8:06 am

    You can try setting up Gmail as an Exchange account in Mail too. Or, try setting it up as IMAP. See which of those behaves how you want it to behave.

    Cyrus Dubash
    8/3/11 @ 8:16 am

    I tried Exchange and like always I put the server address as m.google.com but it says it is not recognized !

    Cyrus Dubash
    8/3/11 @ 8:16 am

    it is IMAP at present and the minimum setting is ONE MINUTE to check mails ! Push is not there !

    Cyrus Dubash
    8/3/11 @ 8:25 am

    I have ticked marked this setting in Preferences ADVANCED – “Use IDLE command if the server supports it” the help explanation for this is – Specify that the server should notify Mail when new messages are available for your Inbox. This method is known as “push email.” This option is available only for IMAP accounts.

    When this option is not selected, Mail checks for new messages by connecting to and querying the server at regular intervals.

    But here the PUSH feature does not work and does not deliver the EMAIL immediately.

    I know that is nothing wrong with 1 minute but was wondering with IDLE checked marked, it still isn’t working…as it should !

    hq
    8/15/11 @ 4:55 am

    You can Push Gmail mail to Apple Mail:

    Check:

    http://hints.macworld.com/article.php?story=20080811071447172

    Go into Mail » Preferences » Accounts (Advanced) and CHECK “Use IDLE command if the server supports it”
    Go into Mail » Preferences » Accounts (Advanced) and UNCHECK “Include when automatically checking for new messages”
    Go into Mail » Preferences » General and set “Check for new messages” to “Manually” (unless you have other accounts that do not support IDLE.)

      rodrigo
      3/30/12 @ 7:39 pm

      Thanks! It does work perfectly!

      jr
      8/31/12 @ 2:17 am

      Oddly, was never an issue on two prior MBPs. Just got a mid-2012 MBP w/ Lion and noticed that I have to frequently click the retrieve new mail button … annoying.

      Thanks, hq … worked like a charm!

    jsr
    9/5/11 @ 6:53 pm

    hq,
    Thank you! That worked perfectly, and makes things much better synced between my mac and iPhone.

    Brandon
    7/30/12 @ 10:49 am

    Does Gmail still support IDLE for Mac (not iOS)? Because I’ve enabled the option on my Mac computer, but it doesn’t get the pushes from the server….

    Brandon
    7/30/12 @ 11:01 am

    Just so everyone else knows, the SOLUTION to making it work is to make sure to restart Apple’s Mail.app after you check the IDLE box. Gmail will now push for me, but it didn’t push until I quit and re-opened my Mail.app.

    Randy
    2/21/13 @ 9:43 am

    Yep, hq’s solution worked for me as well just make sure to restart Mail.app like Brandon states.

Comments Closed.