Forum Question: App Install Failure

I tried to install an app today (Tesla Toy) and the installation was interrupted by a message that iTunes had AGAIN changed the terms and conditions and I must first read them and agree. In the meantime, it stuck the beginning of the app on the next available location and said “Waiting”. So I clicked ok to read the terms and conditions and agreed to them. Then I was taken back to the page in the App Store to start the installation.

The app was marked as free, so I touched it to go to Install App and it installed it. But not where the shell of the icon was waiting, it started a completely new installation and completed it. Now I still have this shell of an icon in seemingly permanent “waitingdom” and I can’t get rid of it. I tried holding my finger on the app shell to get the x’s that then let you delete an app, and they all got x’s except the shell of the one I want to get rid of.

Any ideas?
Shirl Parker

Comments: 2 Responses to “App Install Failure”

    11/1/10 @ 2:29 pm

    There are a few things you could try:
    1. Sync with your computer and use iTunes to delete it.
    2. Restart your iPhone and see if deleting it will then work.
    3. Delete the good app using the regular method or #1 or #2 above. See if that clears the bad one. Or, perhaps you must first delete the good one, then the bad one.

    Shirl Parker
    11/1/10 @ 2:52 pm

    Option 1 worked.

Comments Closed.