Forum Question: Appearance of the webpages in Safari

I have quite often noticed that most of the webpages I visit (including “”) when using Safari, have a certain problem with the appearance (size) of the words in headlines or in passages. I have already experimented using “zoom in” or “zoom out” or even by choosing smaller fonts in Safari’s “Appearance preferences”, but without any good results.
The only solution seems to be “zooming in” the whole page (not just the text), but this action produces a less “sharp” layout of the whole webpage. This problem doesn’t seem to exist in Firefox because it seems that it uses smaller fonts.
Any ideas on solving this problem?

Comments: 12 Responses to “Appearance of the webpages in Safari”

    8/25/11 @ 7:31 am

    It does sound like you are using “zooming.” In addition to zooming in and out, did you try View, Actual Size? Definitely set it there.
    Also, in Safari Preferences, Appearance, what do you have set there?
    At “Actual Size” the pages should look right. If they are less sharp, then perhaps you have a second problem where your screen resolution is not set to the native resolution of your screen. Change it to the highest allowable resolution and that should make things sharper all around.

      8/25/11 @ 7:58 am

      The problem I describe exists when the webpages are set to their actual size. My screen is also set to its highest resolution (1920X1080)
      My appearance settings are: Standard font: Lucinda Grande 13
      Fixed-width font: Lucinda Grande 13
      Default encoding: Western (ISO Latin 1)

        8/25/11 @ 8:38 am

        I’m not sure what it could be then. I’ve got Arial 14 and Courier 12 as the two font settings. But that shouldn’t make a difference on most web sites.

          8/25/11 @ 10:49 am

          Allow me a specific example:
          On “” home page, the phrase “Video Tutorials, News and Insights for Apple Users” under “Macmost” logo, takes up two lines (the second line for the word “Users”). The word “Users” looks a little displaced. In Firefox, the same phrase takes up just a single line and looks in the correct place. (Actual size in both Web Browsers)
          Perhaps it’s something to do with HTML parameters??? Thank you anyway!

            8/25/11 @ 11:02 am

            That should definitely take up only one line. So you are seeing it incorrectly in Safari. The HTML is right and it looks fine in any version of Safari I test it on. So it must be something about how you have Safari set up. Unless you have somehow removed the font “Verdana” from your Mac (standard font).

              8/25/11 @ 11:49 am

              Does default encoding have something to do with it?
              Nevertheless, the Verdana font exists but I have not chosen it. Should I?

                8/25/11 @ 12:09 pm

                No. No need to choose it for anything. Your default encoding is fine.

                  8/25/11 @ 12:51 pm

                  Regarding the “Safari set up” you mentioned before, I found “The guilty guy”: I had inadvertently switched the Universal Access Parameter (Preferences>Advanced>Universal Access) to size 14. That caused the whole problem. Now I set it to size 11 and everything is OK.
                  Thank you for your help.

    Mr Anthony Cotton
    8/25/11 @ 12:35 pm

    I have no trouble at all with Safari. My settings are – Standard Font Times 16-
    Fixed-width Font courier 13 I always have it set to actual size. I have just recently started using the zoom.

    jac mills
    8/26/11 @ 5:50 am

    Gary: Don’t know what I would do without your helpful advice as I read MMost. Do you have a suggested font size for Macbook 13″. Some pages are small type, some larger, it seems. Maybe my overall settings probably are wrong but I do not know how to go about changing anything, really. Thanks. jac mills

      8/26/11 @ 6:50 am

      Just leave at the default. Don’t mess with those settings or it will break some web pages — and most web pages don’t use default sizes anyway.

Comments Closed.