Forum Question: Apple mail, sending pictures

Before I installed Lion I could send pictures from iPhoto with Mail. Now I can still send mail, but not with added pictures from iPhoto. Anyone tell me how to do it? I get the following message: “Mail got error: Can’t make {} into type rich text.” Thanks
jac mills

Comments: 11 Responses to “Apple mail, sending pictures”

    9/14/11 @ 9:09 am

    There are so many ways you can attach a picture to an email message (drag and drop, select from list, media browser, send from iPhoto, etc). Can you explain which method you are using, step-by-step, and where in the process the error appears? Also, which version of iPhoto are you using?

      5/12/12 @ 10:46 am

      I am having the same message: I can’ t find solution.
      I am using iPhoto 11 version 9.2.3

    9/14/11 @ 8:59 pm

    Here’s a circuitous route for us luddites: in iPhoto, select the photo you want to attach to Mail. Click “File” “Export” then select JPEG quality “low(smallest size) – then name and save to wherever – i.e. “Documents” (two-step process — watch the boxes and fill in the blanks/answer the questions.)
    Compose your Mail message and select “File” “Attach Files” – then surf to wherever you stored the picture and select it. This might seem a bit much, but gives you the option of “customizing” a photo for various recipients. (try custom/width/500) for your friends with handhelds.)

    jac mills
    9/15/11 @ 1:55 pm

    Thanks for your help. However, with Snow Leopard I merely had to click on the photo, then the Mail icon in the dock, then send,and it was gone. Lion is complicated is it not?

      9/15/11 @ 2:12 pm

      You clicked the photo in iPhoto, and then launched Mail and it sent it automatically? I don’t remember it ever working like that. Surely there were more steps. Otherwise, how would you go from iPhoto to Mail without sending a photo each time?

        jac mills
        9/15/11 @ 4:37 pm

        The only step I left out, Gary, was typing to whom it was going. So with Leopard, for me, it was:

        1. Click photo in iPhoto library(could send more than one)
        2. Click Mail icon in dock, Mail opens in new window with photo(s) attached
        3. Type in address
        4. Click Send

        That was it.
        Sorry for the omission.

          9/15/11 @ 5:03 pm

          I’m still not seeing it, sorry. I’m trying it on an old Mac with Snow Leopard. But clicking on Mail in the Dock just switches to Mail. It doesn’t automatically create a new message. I can click the Share button and then Email and create a new message from inside iPhoto. But if I switch to Mail then I just switch to Mail, it doesn’t automatically create a new message.

            jac mills
            9/18/11 @ 7:36 am


            Sorry to be such bother, which I am certain is because I do not understand a lot about computers and terminology. But I have described as best I can the method I used to send pics using Mail with SL. Now I can do that –even with Lion. I don’t know how it works, it just does. I hope I am not confusing anyone(other than myself), and apologize if I am. I think I had better leave it at that to avoid further disruption, and keep my fingers crossed so that my Mail keeps working as it does. Thank you.

              Mark Howard
              2/13/12 @ 1:58 pm

              Hi, did you ever get a resolution to this error? I am getting it as well.


    Ellen Artigas
    3/1/12 @ 7:26 pm

    Hi Gary, I sent a photo (from iPhoto 11 9.2.1) to my email using “share” on bottom right and then “email”. Put in email address etc. iPhoto showed it was sending and then “one photo was emailed”. When clicking on “i” and “sharing” it shows it was emailed; the problem is I never got the photos (on Mac (10.7.3), iPhone 4 or iPad2 and I tried with many different photos. I have sent pictures in the past and it worked….. so what happened? Thanks

      3/1/12 @ 10:49 pm

      No way for me to know what happened. Did you try again? Perhaps your email service/server didn’t like the size of the photo or it went to junk. Could be any number of reasons.

Comments Closed.