Forum Question: Back to my Mac with Double-NAT

is there any way to use Back to my Mac if the Time Capsule does not directly receive the external IP-address? (Double-NAT problem)
My ISP distributes internal IP-addresses and I am connected via optical fiber, so there is no way to get my statical, external IP address to my Time Capsule directly or use PPPoE. However, if I connect by “command+k” I can type in my static address and I do have access (ISP said that all ports are open from their side). Maybe there is a way to enter the static IP-address somewhere so all the services including mobileme forward this address instead of the internal ISP IP-address.
—–
Manuel Haefele

Comments: 3 Responses to “Back to my Mac with Double-NAT”

    3/22/11 @ 6:44 am

    MobileMe’s Back to My Mac feature should work, yes. But I’m not sure of your exact situation. You say you have a static IP address? That should make it even easier for it. But you say you have a double-NAT? Well, then why not have your Time Capsule specifically port forward the file sharing ports to your Mac, and have your Mac on a fixed IP address inside of your inner NAT. You can do that all by familiarizing yourself with the Airport Utility application on your Mac.
    See episode 345: http://macmost.com/setting-up-an-airport-extreme-for-outside-access.html

      manuel haefele
      3/25/11 @ 9:12 am

      Hi Gary,
      accessing my mac is no problem at all. What I would like to set up is that my other macs and my TC are shown in my finder when I am not at home but online with my mac. that only works with mobileme but because of this double-NAT problem, it does not work. As I figured out, mobileme forwards the IP address from Time Capsule but this IP address is an internal one (given to me by my ISP and I cannot change that). So I need to change the IP address mobileme is using. I cannot e.g. enter a second external IP into Time Capsule which would solve the problem.

    Michael
    4/8/11 @ 8:50 am

    Put one of your devices in bridge-mode

Comments Closed.