Forum Question: External HDD suddenly not being read

My WD external HDD of 1TB was plugged in and I was copying some files. In between I had to leave so I tried to close the Finder window but it stayed open, though the copying stopped. I waited a while then pulled it out from the USB port without ejection (by mistake).
Now when I plug in, the external HDD is powering up from its power source and light is on, but when I connect to the USB, it’s not being read/showing up on the Mac, not even on Disk Utility.
Any tips?
—–
Jonty

Comments: 2 Responses to “External HDD suddenly not being read”

    9/28/11 @ 1:53 pm

    If it is not showing up in Disk Utility, then that spells trouble.
    Did you try hooking it up to a different computer?
    Did you try restarting your computer and doing it again?
    Before you do that verify that you didn’t somehow damage or loosen the USB cable.

    Jonty
    9/28/11 @ 11:19 pm

    Yup I’ve hooked it to another comp, no luck. I changed the USB cord and tried, but it’s not reading in. But the lights are on, so the power is feeding the HDD; something is preventing it from being read. When I had force ejected it, the warning had popped up about it being not advisable, but it has happened before often, with no damage; this seems to be the first time.

Comments Closed.