Forum Question: How Can I Selectively Remove Auto-typed Addresses In Mail?

MAIL/Window/Previous Recipients contains all the addresses that I would like to have Mail complete. The problem is that many addresses are not on this list but they still show up when I begin to type an address. I am paranoid about the wrong recipient getting all my important secrets. :)
—–
brad

Comments: 4 Responses to “How Can I Selectively Remove Auto-typed Addresses In Mail?”

    4/14/16 @ 11:07 am

    Another place these come from is from Contacts. Make sure they are not in your contacts. If they are not in your contacts and not in your Previous Recipients, then they should not appear in autocomplete. Maybe restart Mail (or log out or restart) and check the Previous Recipients again.

    brad
    4/14/16 @ 7:21 pm

    Addresses that I might have used only once and over a year ago still appear when I begin to type an address. They appear in a separate list under “Found In Mail” and after the addresses that are in my Contacts. I don’t see them in Previous Recipients and they never were in my Contacts. Actually, I’d rather not see all the addresses from Contacts either. Previous Recipients are the only ones I want to see. Mixing up emails among my Contacts would be a problem, too.

    Marshall Coman
    4/21/16 @ 9:07 am

    Even though I delete email address either in my contacts or as they appear in address bar in email. When I delete them I wish it would not appear again.Thanks Marshall

    Drewski
    4/25/16 @ 7:38 pm

    I know you looked in the “Previous Recipients” list, but that list can be tricky. Try starting a new email as usual, and type on the “To:” line until the name in question pops up. Hit enter. You should see the name you want to delete. Hover your pointer over that name and click on the drop down arrow to get a list of options. If this is a name that is NOT in your contact list, you will get the option to “Remove from Previous Recipients List.” Click and it’s gone. Works for me.

Comments Closed.