Forum Question: How Do I Get OS X Messages To Insert Period & Capital Letters Like My iPhone Does?

When I text from my iPhone, it capitalized first letter of each sentence and puts a period at the end of the sentence and puts in an apostrophe for contractions. Can I get OS X messages to do this too? From my phone, my text look grammatiCally accurate; when I text from my Mac, I look grammatiCally challenged. I know I can take the time to do these things when I’m typing, I’m just wondering if there is a way to tell the computer to do it automatiCally.
Thanks Gary!
—–
Kendall

Comments: 5 Responses to “How Do I Get OS X Messages To Insert Period & Capital Letters Like My iPhone Does?”

    12/3/12 @ 10:54 am

    The feature you are talking about on your phone is “autocorrect.” It does this on the phone because it can be harder to type on a small phone keyboard than on a real one. Also, I think, because people are often walking around and in a rush when typing on a mobile device.
    You explain what is good about autocorrect. But what is bad about it is that it sometimes gets things wrong when your word is way off. For instance, you may “break up” with your significant other instead of “make up” with them. Things like that. It makes for some laughs too.
    On your Mac, there is the same feature, but it is turned off by default. In Messages, go to Edit, Spelling and Grammar, Correct Spelling Automatically. Then you’ll find that at least spelling is correct — doesnt becomes doesn’t without you needing to type the apostrophe.
    But it won’t help with other things like adding periods automatically and such. Maybe text substitutions can help you with that? http://macmost.com/using-text-substitutions-in-snow-leopard.html
    Just watch out for those unintended autocorrections!

    Kendall
    12/3/12 @ 11:04 am

    From iPhone : Thank you sir!
    From Mac : spank you sir

    Just kidding

    Kendall
    12/3/12 @ 3:11 pm

    I selected the ‘Correct Spelling Automatically’ option but it doesn’t automatically correcting my typos. All it does is red-dash underline what I misspelled. I still have to correct it myself or choose the correct spelling out of a list of suggestions. And it doesnt put an apostrophe where needed either. Suggestions?

      12/3/12 @ 3:12 pm

      Did you try quitting and restarting the Messages app to see if that helps. Try that, and then test it by typing something I know works: “doesnt” (leave out the apostrophe.

    Kendall
    12/6/12 @ 12:13 pm

    Ahhh…That fixed it. Thanks Gary. You’re the best.

Comments Closed.