Forum Question: How Do I Make My External Drives, Show Up On My Desktop ???

My iMac is running, El Capitan Version 10.11.4. I just restarted my Mac and my (2) two drives stoped showing up on my desktop. I have an external storage drive, so that my computer Hard Drive does not fill up and I have a External Drive that I use with “Time Machine” !!! I’ve checked, with “Disk Warrior” to see if anything is wrong with my drive and have rebuilt the Disk Directory and everything seems to be working fine, except for the fact that I cannot use these drives !!! What should i do ???

Thanks for your anticipated help, Gary !!!
—–
Louis M Castrello

Comments: One Response to “How Do I Make My External Drives, Show Up On My Desktop ???”

    4/14/16 @ 9:18 am

    So these drives are definitely connected, and you can use them, but they just aren’t showing up on your Desktop as icons and you want them to?
    In the Finder, choose Finder, Preferences. Then go to General. Then look at Show these items on the desktop. Check “External disks.”
    If, on the other hand, the problem is you cannot access these drives at all, then I would try shutting down your Mac, disconnecting the drives, reconnecting them, and booting up your Mac again.
    If they still do not appear, then you may need to get firsthand help to figure out what is wrong.

Comments Closed.