MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Make Text Boxes Behave Consistently?

I must have multiple text boxes in some master pages. Only one is the ‘body” place holder and the second and beyond are “defined as text place holder.” Clunky but OK.

Both text boxes have 5 levels of bullets with indents, weights, etc set the same specific way. When the slide is “reset to master layout” the ‘body” text box follows the set style but the defined text place holder does not. I then have to reformat every text box individually and that is all lost if I Reapply the Master again.

If the body text box on the slide itself is copied and then the master reapplied it reverts to a indented but center-justified version of the default master settings. So now the three text boxes look completely different.

I know I can make multi-columns in the body box but unfortunately that would be at least as unwieldy for the unskilled people who will have to use this.

Am I missing something? Is there a way to make the text boxes easy and consistent? Thank you.
—–
LVogt

Comments: 3 Responses to “How Do I Make Text Boxes Behave Consistently?”

    3 years ago

    (In Keynote, I’m assuming)

    You’ll need to experiment because I’m not sure how you have things set up. So some ideas to get you experimenting.

    First, make sure that the style is applied to the entire box, all the text in it. I’ve seen things like this happen when the first character or first line of the box is blank and has a different style.

    Second, make sure you are only using styles. Create new ones if you need to. In other words, each text box should use a defined style exactly as the style is, not with extras: bold, font size, etc. If you are using customizations outside of the defined style, then re-define the style to match it or create a new style. Perhaps you are using a style, like “Body” and then apply your own custom changes, and then when you reapply the master it is going with the actual style settings and not your changes.

    Just keep going with ideas like this. I can’t really guess too much about your situation, but if this was happening to me I would simply keep experimenting and trying things until I figured it out. That’s what you’ll need to do.

    LVogt
    3 years ago

    I’ve tried a lot of things. You kind of described part of the problem. You can’t customize at all except one text box at a time which a huge time waster. The “defined” text all changes to the style of the first line as it’s set in the “body” and all indentation, bullet customization is lost. Copy the ‘Body” on the slide and reapply and it changes to “Caption” style. Less than useless. So, I know what it does and it’s counter-productive. I just need a solution if there is one.

    3 years ago

    Oh, so you are trying to apply different styles to different parts of the same field? That’s the problem. Instead, break this up into multiple fields. Make that first line its own field, and the bullet points another field.

Comments Closed.