MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Stop Messaging From Showing Up On All Of My Devices?

I prefer to have messaging only on my iPhone Xr but not on my iPad or iMac.
How do I stop messaging from showing up on the latter two?
Thanks for your help!
—–
Gayle

Comments: One Response to “How Do I Stop Messaging From Showing Up On All Of My Devices?”

    3 weeks ago

    What type of messaging? Do you mean SMS text messaging? Or iMessages?

    For SMS, if you are getting those messages on your iPad and Mac, then go on your iPhone to Settings, Messages and look for Text Message Forwarding. Go into there and turn off the devices you do not want your iPhone to send SMS messages to.

    If you mean iMessage, then you’ll need to disable Messages on those devices in the iCloud settings for each device. On your Mac, go to the Messages app, then Messages, Preferences, then disable any accounts under iMessage. ON Your iPad it is in Settings, under Messages, turn off iMessage.

Leave a New Comment Related to "How Do I Stop Messaging From Showing Up On All Of My Devices?"

:
:
:
0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)