MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Stop Receiving Emails (Advertisements) In Spanish?

About a month ago I started getting emails in my Apple mail that are in Spanish. I do not speak or read this language. I get between 4 and 10 of these emails a day. I put them in junk, but this still continues to happen daily. Can I eliminate this from happening?
—–
Arnie Schwartz

Comments: One Response to “How Do I Stop Receiving Emails (Advertisements) In Spanish?”

    3 months ago

    First, I would check in https://appleid.apple.com and see what your language settings are. Did they somehow get changed to Spanish there?

    If not, perhaps you are getting someone else’s messages. Someone could have signed up for a list and entered your email address by mistake — perhaps it was one letter off or something. This happens to me quite often.

    In that second case, I would just look at the bottom for an unsubscribe link. If you can’t tell what it says at the bottom of the message, you can always copy and paste the text into https://translate.google.com and you can usually figure out which words are the ones to click on.

Leave a New Comment Related to "How Do I Stop Receiving Emails (Advertisements) In Spanish?"

:
:
:
0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)