MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Stop the Mac From Creating Emails In the Draft File?

I am using Mojave on my brand new laptop AIR.
I have called Apple and then do not seem to know why the mail system (using Mail) creates Drafts of emails often, even without me asking it to do so? I type and email and send then often a partial version of the email shows up in draft? I have no set it to do and the email is always completed and send, so why only a partial is saved in draft mode?
Does not happen all the time, but maybe 25% of the time. Seems random and happens regardless of who I email to.
—–
Ted Cohen

Comments: 3 Responses to “How Do I Stop the Mac From Creating Emails In the Draft File?”

    8 months ago

    Like with most things that have to do with email, the issue is related to your email service, not the Mail app on your Mac. For instance, if you use Gmail, then Gmail is creating the drafts and saving them. That is part of Gmail. And it is a good thing, as it autosaves these drafts and allows you to recover if you have a problem while in the middle of writing a long message. You can also start writing a message on one platform, and then pick it up later on another platform. For instance, you can start writing using the Gmail web site, and then find that draft in your Drafts folder on your iPhone later on to finish. So Drafts can be useful. And they don’t really cause any trouble. You can just ignore your Drafts folder.

    You can’t stop using Drafts, but you can make one change. In Mac Mail there is a setting for this. Go to Mail, Preferences, Accounts. Choose your account. Then under Mailbox Behaviors there is a setting for Drafts Mailbox. You can switch it to “On My Mac / Drafts” and those drafts will be stored locally. Or, you can leave it as the Gmail Drafts mailbox. Locally means you won’t see these on your iPhone or other devices. And it usually means fewer drafts.

    The way Gmail should work is that you get a Draft email saved in the Drafts folder while you are writing. Then when you send an email, it goes away. But I think it sometimes gets left behind if the connection between you and Gmail isn’t great. Could be a physical connection thing. Or, it could be the way you have set up the account in the Mac Mail app. For instance, when you go to add an account, you can choose “Google” as the account type — that is the best way. But you can also choose Other and then configure Google as an IMAP account. That is how you had to do it a long time ago. The IMAP method I think causes issues like more drafts sometimes.

    But the bottom line is that you don’t need to really worry about it. Just ignore your Drafts folder.

    Ted Cohen
    8 months ago

    Thank you so much!

    justicepig
    8 months ago

    Very interesting scandal google has, so no matter what, there is no checkbox to now dis engage the draft process, either its done locally or unto another folder, to rack what your typing!

Comments Closed.