Forum Question: How Do I Synchronize Messages Between iPhone 6s+ and iPad Air?

I review most messages during the day on my iPhone. When I get home at night, and turn my iPad, all those messages pop up again! If I’ve read a message on iPhone, I don’t want to see it again on the iPad. How do I make that happen?
—–
E Bond Francisco

Comments: 5 Responses to “How Do I Synchronize Messages Between iPhone 6s+ and iPad Air?”

    10/3/16 @ 6:33 am

    What do you mean by “pop up again?” If you mean that they are in the Messages app, then that IS your Messages syncing. You should see the same ones between both devices. When you look at them on your iPad they should be there, all marked as read.
    However, if you mean you get new notifications when you look at your iPad, then that shouldn’t happen. I get my Messages on my iPhone, iPad, and two Macs. They all stay in sync and I get notifications at the same time on each.
    Perhaps check and double-check your iCloud and Messages preferences/settings on both devices. If that doesn’t help, then a trip to the Genius Bar with both devices is in order.

    E Bond Francisco
    10/3/16 @ 9:44 am

    Thanks Gary! I didn’t state that quite correctly. Once I’ve responded/acted on a message on my phone, I DON’T want those messages to come up again on my other devices. That becomes a nusance.

    10/3/16 @ 9:48 am

    So my original questions still stand: Are you talking about notifications? Or are you talking about simply those messages existing in the Messages app? In other words, what do you mean — exactly — by “come up again?”

    E Bond Francisco
    10/3/16 @ 11:36 am

    Oh gosh, sorry! I’m talking about notifications – DOH! – AND messages. Once I’ve read a message on one of my devices, I don’t want to see it again when I open another device. Once I’ve seen a notification on one of my devices, I don’t want to see it again when I open a 2nd device. Thanks for helping me to ask the right question! Hope I’ve got it right this time!

    10/3/16 @ 12:25 pm

    OK, I see. They should stay in sync. So the notification shouldn’t still be waiting for you later. And it should show as “read” as well. Not sure why it isn’t working for you. Perhaps try logging out and back into your Messages account on both devices, maybe? Or just take them both to the Genius Bar and show them the problem as it is happening.

Comments Closed.