MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Turn Off Horizontal Scrolling On the Magic Mouse?

I love the Magic Mouse, but I hate the horizontal scrolling because it is too sensitive and hard to control. Accidental swipes often takes me back a few pages in many applications. Especially web browsers. Is there any way to turn this off. I know of MagicPrefs, but it no longer works in the latest MacOS versions.
—–
Jean-Claude

Comments: 9 Responses to “How Do I Turn Off Horizontal Scrolling On the Magic Mouse?”

    2 weeks ago

    I’m not using a Magic Mouse, but trackpads all around. So I can’t test this. But this Terminal command should set a preference to disable that. Probably the same one that MagicPrefs set.

    defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO

    Try it and let me know if that has the desired effect.

    Ian Gibson
    2 weeks ago

    I think if you go to System Preferences >> Accesibilty >> Mouse and Trackpad, you might be able to turn it off there.

    Clay Sisk
    2 weeks ago

    System Preferences – Mouse – Point & Click – Uncheck “Swipe between pages”

    Clay Sisk
    2 weeks ago

    Oops, not Point & Click, but “More Gestures” pane.

    2 weeks ago

    Clay: Thanks Clay. I can’t see the Mouse preference pane on my MacBook Pro because it only appears when there is a mouse present.

    Jean-Claude
    1 week ago

    I already have the “Swipe between pages” option turned off. What I mean is I don’t want any horizontal movement at all from the mouse. When in a Finder window in list view, if I accidentally swipe a tiny bit to the left, the disclosure triangles disappear. Hard to control. I tried the terminal command but it does work. I guess it used to work prior to Sierra.
    Gary, now that I input the command you suggested in Terminal, should I input another command to cancel it?

    Jean-Claude
    1 week ago

    Mistake in my previous comment : I meant to say “it does not work”

    1 week ago

    Jean-Claude: You could cancel it, yes. But all it does is set “MouseHorizontalScroll” to “NO” and if MouseHorizontalScroll isn’t used in Mojave then it makes no difference if you set it to YES.
    If there is no way to change this, then it may just be that the mouse isn’t for you. Maybe think of switching to a trackpad? Or, you could get a third-party mouse that doesn’t have a touch surface.

    Jean-Claude
    1 week ago

    Got it. Thanks everyone for your help!

Leave a New Comment Related to "How Do I Turn Off Horizontal Scrolling On the Magic Mouse?"

:
:
:
0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)