Forum Question: How to force FaceTime on Mac go through proxy/socks

Is there any way to force the facetime on mac go through proxy/socks. Because the mac is behind the firewall, it can’t reach to the internet directly. I have setup the proxy/socks in the network setting, but no luck, it got fail.
I have tried to use the wireshark to capture the traffic, in the beginning, it used the socks without problem, but it change to apple’s server after a few handshake.
Thank you
—–
Marco LAW

Comments: 10 Responses to “How to force FaceTime on Mac go through proxy/socks”

    12/9/10 @ 8:24 pm

    You’ve got to open up the correct ports. Have you tried to set port forwarding for ports 53, 80, 443, 4080, 5223, and 16393-16472 (UDP) to go through to your Mac?

    Marco Law
    12/9/10 @ 9:21 pm

    Instead of the port forwarding, any other way?
    Because I will have more than 1 MAC/Iphone wanna to use the facetime.

      12/9/10 @ 9:32 pm

      The ports have to forward to a single machine. Have you tried shutting off the Firewall? Do you have some pressing need for the firewall?

    Marco Law
    12/9/10 @ 9:36 pm

    I have tried to connect the mac to the internet directly, it works.
    Yes, I can’t turn the firewall off as I have security concern.

      12/9/10 @ 9:41 pm

      It’s a trade-off then. You are concerned about security, so you have a firewall. But that firewall prevents you from doing something you want to do. Not sure what your security concern is, but perhaps you should look into that more.

        TheFrog
        7/13/11 @ 9:05 am

        Do you not see any security concerns in connecting every computer at my home network directly to the internet ? I mean you cant be serious about this statement, can you ??!!
        I see then you do not have to much experience with computers and networks in general.

          7/13/11 @ 9:51 am

          What do you think may happen? If you have a password set for access to whatever sharing you have turned on, then you need that password. Without it, no access.
          I’m not saying that everyone should turn off their firewalls. But this person was having trouble using his computer. It is true that not using your computer is safer than using it.

    Ralfsj
    12/16/10 @ 8:12 pm

    Have a new iMac and trying to do face time. I get stuck in the sign in stage. Even creating a new apple id does not work. Any help here? Apple guys said I do not need to open any ports since I am using Airport Extreme. Some other people say to connect to anotehr network and return to yours and it will work. Have not tryed that yet but is does not make sense to me.

    Ghostofrecon
    4/9/12 @ 12:13 pm

    Wow.I know I’m late to the game on this post, but all that I can say is that this is exactly the Mac standpoint on security. “Our software doesn’t work with your security settings? Just disable them.”

    Ghostofrecon
    4/9/12 @ 12:15 pm

    Also, exposing your mac to the internet is a great way to become a target. Having exposed surfaces through with services can be mapped is like having a large red bullseye on your head. …ridiculous.

Comments Closed.