Forum Question: iMovie 09 won’t play inserted picture

I’ve inserted 2 pictures from my iPhoto library into the project library timeline in iMovie ’09, but iMovie won’t play or export the images. One of them will show up in preview, but it also shows up for the second image I’ve inserted as well. It’s almost as iMovie is just indicating there’s an image and it’s using whichever one I dragged in the timeline first to represent both. When I play it or export it, the original video that I “replaced” shows, but it acts now as a still image with the Ken Burns effect on it. I have separated the original video from the audio and left the audio track playing while the images are supposed to display. Do you have any idea why this might be happening? I’ve spent hours updating my computer, fixing permissions, etc. and nothing seems to help.
—–
Sue

Comments: 6 Responses to “iMovie 09 won’t play inserted picture”

    9/12/11 @ 10:55 am

    Where are these images? Are they files? Are they in your iPhoto collection? Anything special about them (they are very large or very small).
    Have you tried creating a new project and just using one or both images in it to see if that works?
    Are you actually exporting the movie (Share) to test it? Or do you mean something else?
    Have you tried other images — to see if the problem lies with these two only?
    Have you thought about upgrading to iMovie 11 (been out for a while) — I figure if you are going to spend so much time solving the problem, why not solve it for the current version of iMovie, not the old version.

    Carlos
    1/21/12 @ 12:18 pm

    i have the exact same problem

    Mat
    1/24/12 @ 2:00 pm

    Same problem here…
    Some stills export ok and others do not..
    tried replacing OK mages with not ok images and still the same issue..
    ???

    Kris McGuire
    6/27/12 @ 10:51 am

    I use iMovie11 and have the same problem. I have made dozens of movies with both video and photos imported from iPhoto with no problem. Now, suddenly, the imported photos won’t appear in the finished product.

    Brian
    11/30/12 @ 9:38 pm

    I have the same problem too. For me, it was working fine until I updated my OS to 10.7.5. Now, no matter which photo I try to load into my project, it always reverts back to first photo that I loaded since the software update. It’s very frustrating. Furthermore, even though my photo shows up fine in the timeline, it comes up black in the player.

    Ruelon
    12/22/12 @ 9:27 pm

    I have the same problem!! Any fixes?

Comments Closed.