Forum Question: iMovie Photo and Music icons are grayed out

I am using iMovie 11 and I am working on making a movie from video footage that resides on my attached USB drive. I am trying to add photos to the movie, via the storyboard/shots part of the project, but the icons for the photo, music, text, etc., are all grayed out. They are also grayed out in the menu. How can I get the media icons to not be grayed out?
—–
Ian Cooke

Comments: 13 Responses to “iMovie Photo and Music icons are grayed out”

    3/10/11 @ 7:59 am

    Do you have any photos in your iPhoto collection? If not, then that could be why it is grayed out. How about just dragging and dropping what you want from the Finder into iMovie? That works too.

    Ray
    8/17/11 @ 7:51 am

    I have upgraded to LION OS and cannot drag and drop photos into iMovie nor use the buttons as they are greyed out.

      8/17/11 @ 8:04 am

      iMovie hasn’t changed. Are you dragging into the project? You have to drag them into a project, not the event.

    Garrett
    10/23/11 @ 12:12 am

    I am having the same issue. I’ve got the photos in iPhoto, music in iTunes, but many options and commands in iMovie are grayed out. Can’t drag and drop, either.

      10/23/11 @ 9:10 am

      Try resetting your iMovie preferences. Quit iMovie. In the Finder choose the “Go” menu with the option key held down (I am assuming you have Lion) and choose “Library.” Then look for the Preferences folder. In there, look for com.apple.iMovieApp.plist. Then trash it. Then start iMovie again.

    Mike
    3/5/12 @ 11:08 am

    This is a great tip – thank you – BUT keeps coming back – any ideas?

      Carmel
      4/29/12 @ 4:58 am

      Agree, tips all good but I am having same issue and none solving it, have you had any luck sorting this? Any help would be great!

    Evelyn
    6/23/12 @ 3:35 pm

    Same thing is happening to me. I can’t load pictures in my movie trailer or music. I tried the tip Gary suggested and nothing changed. Help!

      6/23/12 @ 3:51 pm

      Trailer? If you are making a trailer, then that’s the reason. Trailers only use video. You can’t use photos.

    Sandra
    1/8/13 @ 11:05 am

    I feel like I’ve tried everything…I imagine I am missing something, but no one seems to be able to hit the spot. It did work for me a couple months ago, but somehow, the Gods took my privilege away and now my life is grey…literally.

      1/8/13 @ 11:07 am

      I’d have an expert/friend take a look, or the Genius Bar. It is probably something simple that changed but it is hard to guess at what if could be without it in front of me.

    Sean
    1/9/13 @ 5:06 pm

    Haven’t tried this yet but Gary said that it only takes video and I have the same problem too. I was just thinking that if it’s possible to take a photo and change the extension name to a mp4 or something like that.

    Sean
    1/9/13 @ 5:14 pm

    Just a follow up. I have changed it and have put it into iMovie. I then imported the folder of which the file is in and dragged it into iMovie. It worked but there’s only one holdback. The picture lasts 0.1sec. It doesn’t let you place the image in the slot on the storyboard.

Comments Closed.