Forum Question: Internet connection not working


I have been trouble accessing various programs that need the internet to update and download stuff (itunes for example) but for some reason it doesn’t connect to the internet. I have firefox and that works fine. I also have Chrome but that doesn’t work either it comes up with the same error message.

Any Ideas?

— Fergus Oliver

Comments: 10 Responses to “Internet connection not working”

    6/19/10 @ 6:59 am

    That’s very strange. Do you have any special proxy settings? If not (or you don’t know what that is) then I’d say it is impossible to tell what could be wrong — you need to have someone check it out.

    6/19/10 @ 10:07 am

    I had the same problem a couple months ago. I found out what caused the problem: a proxy – more specifically, the Webproxy (HTTP). After I turned it off, everything worked as it should. Afterwards I checked on forums and it seems that others had run into this problem as well. It’s strange because I never enabled that proxy.

    To disable that proxy, follow these steps:
    1. Open System Preferences
    2. Go to “Network”.
    3. Click on “Advanced”
    4. Click on the Proxy tab
    5. Turn off the Webproxy (HTTP) proxy, if it isn’t already turned off.


    Fergus Oliver
    6/19/10 @ 2:32 pm

    Thanks Tommy that worked a treat! fantastic!


    6/19/10 @ 4:25 pm

    No problem! Glad I could help!

    9/9/12 @ 10:09 pm

    Dear Macmost,
    I have a cable modem Internet connection, 10mbps for downloading and 1mbps for uploading. Everything seems fine, I can browse the web, I can watch videos on vimeo, youtube, ustream and other similar websites (so flash and script handlers are OK using Safari), but the problem occurs when browsing specific sites: DeviantArt and Google Plus.

    When browsing DeviantArt/Google Plus, my connection stops. System Preferences shows the Wi-Fi/Ethernet led light green (yes, this happens on either connections, so this is not a wireless issue), but the internet is gone. I can’t browse the web, I can’t use any other apps that use Internet, I can’t get into my router settings (, yet the light is green, I’m still connected.

    I used to deactivate the Wi-Fi or unplug the Ethernet cable, turn it on/hook-up the cable and everything is back to normal.
    Now, I noticed that if I wait a couple of (maybe more) minutes, the Internet is back on by itself, but something mysterious occurs: The Twitter app shows me the last DMs as if I had not read them, even if they are weeks old! (and of course, I’ve already read them).

    This happens every time when browsing DeviantArt/Google Plus (Safari or Chrome, MBP, OS X 10.8.1) This is really annoying, I don’t know what the problem is. What do you think? Any ideas?

    I’m using the OpenDNS servers, but this occurs with Google DNS and my ISP DNS servers too.
    Not using Firewall or Proxy servers. This occurs only on my MBP, any other device connected to the router seems fine.
    Before upgrading to Mountain Lion, I fresh installed Lion.

    Thank you in advance.

      9/10/12 @ 6:40 am

      Impossible to say what the problem could be. Maybe try on a second computer (have a friend come over with a laptop, for example) to see if it is your Mac or the connection. Or, take your MBP to another location and try there.
      Either way, call your ISP to troubleshoot.

    9/10/12 @ 10:46 pm

    After an exhaustive research, I checked my router’s events log and now I know what occurs:
    When I’m on DeviantArt/Google Plus, my internet stops because my router thinks that I’m trying to make a DoS attack!

    This is the log:
    Mon Sep 10 23:16:22 2012 1 Blocked/RST by DoS protection [my own IP address here]

    The OS X Firewall is not activated, but my router’s is.
    What should I do?
    Should I disable my router’s firewall?

    What’s wrong with my MBP? Why this ONLY happen with DeviantArt/Google Plus? :s

    Thank you for reading.

      9/11/12 @ 7:00 am

      Well, try it. See if that works and then you know it is your firewall causing the issue. It would be malfunctioning as you are clearly not making a DoS attack. Perhaps there is some setting that is wrong. I don’t know which router you are using, and I’m not a router/firewall expert anyway. But perhaps you can resolve this by asking someone that is — or just investigating your firewall settings.

    9/12/12 @ 4:41 pm

    The solution, so far:
    I disabled my router’s firewall (turned my OS X firewall on, of course) and I switched my Wi-Fi encryption scheme to WPA instead of WPA2. I think my router is a piece of crap and is unable to handle WPA2 properly.

    Now I can browse the web, and use any other app that uses Internet, like a boss on my Macbook Pro :D [No dropping connections so far!]

    I hope this is helpful to someone else.

Comments Closed.