Forum Question: IPhone 3G sync problems after OS4 update

I have the following problem (searched many other forums already but no solution):
I upgraded my 16GB 3G IPhone to OS4. Initially I tried it via update but the backup got stuck at about 0.5% even when leaving it over night. I then removed my photos and music to see whether this accelerates things, but it had no effect. Then I did restore and the IPhone backed up, installed the new OS and restored the data. So far everything fine. All data seems there, I don’t have an issue with things being slow (its a bit slower but not unbearably slow) etc.
Here is the problem: when I tried to get my photos and music back on the iPhone, every time I sync the IPhone now it crashes during the backup process. I tried to sync it from the button on the overview screen, I tried to restore it once more, restore it from backup by right-klicking it, ticked some music folder in the music tab and then hit apply – everything. The effect is the same: some 10 minutes or so into the backup process that automatically starts, the IPhone beeps, the round progress bar appears and it reboots a little while later (apple symbol etc) before the backup is complete.
While the phone is fully functional at the moment, I cannot get my music and pics back on it and I cannot do a backup ever.
Any suggestion what I can try other than try to wipe it completely and install everything from scratch? The latter would be a shame as I have a lot of apps with data inside that cannot be backed up externally (like diary like programs) and progress on games. I tried to shut it down and hard reset, but this has no effect either.

— Annie

Comments: One Response to “IPhone 3G sync problems after OS4 update”

    6/29/10 @ 7:22 am

    I think I found a solution to the problem myself: I renamed the mobile sync folder in application support. When I then synced again, a new mobile sync folder was created with a new backup and everything went through smoothly.

    Still this post might be useful if someone has the same problem.

Comments Closed.