Forum Question: Is Adobe Reader Compatible With Mojave?

I recently updated the operating system to Mojave on my MacBook Pro. Upon updating I could no longer access Adobe Reader nor could I successfully install a new version of Reader. Any assistance would be greatly appreciated. Thank you!
—–
Rob

Comments: 3 Responses to “Is Adobe Reader Compatible With Mojave?”

    11/8/18 @ 10:27 am

    Perhaps you just have an old version of Reader? I just tried it and it worked fine. The version is Adobe Acrobat Reader DC version 2019.x. You can get it at https://get.adobe.com/reader/.

    Rob
    11/8/18 @ 1:15 pm

    Thanks for the response, Gary. Installation always aborts with the message “Found a higher version Adobe Acrobat Reader in the installation location. Installation will terminate.” Totally confused by this message.
    Thanks again!

    11/8/18 @ 1:16 pm

    Rob: Which versos do you have now? Have you tried deleting it before installing?

Leave a New Comment Related to "Is Adobe Reader Compatible With Mojave?"

:

:

:


0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)