Forum Question: Mail cannot send message using server

Sometimes when I send a mail through Apple Mail I get this kind of message:
With the text: ‘Cannot send message using this server ***’.
I then click ‘Try with selected server’ again a couple of times and finally, after a few more of these popups, it sends the message. It’ll also send at some later time when I click ‘try later’. My mail server settings are fine. And most of the time Apple Mails ends the emails. But occasionally it’ll give this popup saying ‘Cannot send message using the server ***’ What can be wrong? I’m using Imap if that matters.
—–
rené

Comments: 15 Responses to “Mail cannot send message using server”

    5/25/11 @ 3:07 pm

    Just a simple connection problem. Either on your end, the server end, or anywhere in between. It happens.
    Sometimes the real error message isn’t getting through. For instance, the mail server could have a limit on the number of times a connection can happen per minute or hour. When you go over that amount, you get an error. Then later, it clears up. That’s just an example.

    rené
    5/26/11 @ 8:26 am

    Funny thing is that this happened when I switched from Tiger to Leopard. In both cases I used Apple Mail. I’m 98% certain all settings are ok. And 8 out of 10 times emails are sent normally. My colleague uses Thunderbird and she never has problems connecting. With the same number of email accounts setup. It seems to be Mail 4.4 related? Is this perhaps a Apple Mail bug? Which can be fixed?

      5/26/11 @ 9:21 am

      I don’t think it is a bug. But you can’t compare to your colleague. Different connection (on both ends?). Also, since you are using a different client, then some things will be different. For instance, in my example about timing above, it could be that her client accesses mail at different times and intervals, or her server doesn’t have a limit like yours. There are so many factors. If you could get a hold of your server’s mail error log, you might see what is happening on that end.

    René
    5/27/11 @ 1:59 am

    Fact is though that all Apple Mail users at work are having this problem where we periodically get this popup. The Thunderbird user doesn’t. We’re all using the same office server. I’ve changed the interval to 1 minute to check for emails. Other Apple Mail users have it on its standard 5 minutes. I have saved the mail log at the time the connection error message occured through Apple Mail’s Connection Assistent. Can’t find any mention of an ‘error’, but then again, don’t know much about what it all means. Does it matter that I have 6 email accounts setup in Apple Mail? Can I send you this log? Perhaps you can see what could be happining.

    René
    5/27/11 @ 3:14 am

    I’ve contacted our own isp who handles our site and external smtp mail server and they told us to change Apple Mail’s default 25 to port 2525. Have to try it Monday. Would that work better? I can understand it when port 25 would be blocked by our office internet setup. Then I would have to change it to 2525, but then it would also never have worked through port 25 at all! As it is now it works 8 out of 10 times through port 25 and periodically not through port 25? Is that possible and why? I’ll check whether it works better through custom port 2525 anyway…

      5/27/11 @ 6:39 am

      If your ISP suggested that, then try it. Perhaps they have limits on 25 that are not on 2525.

    Carol Luskin
    12/5/11 @ 9:27 pm

    I am having the same intermittent problem and it has nothing to do with settings. I have discovered that it occurs only when there are attachments, pictures or web links that it doesn’t like. Unfortunately, I can’t figure out what is wrong with those particular items but if I delete them, the email goes without error.

      daniel
      4/23/12 @ 7:13 pm

      Im having the exact same problem and Im using go daddy server. totally sporadic.

    Nick
    8/1/12 @ 8:31 pm

    I have been using Mac Mail for a very long time for work too. But all of a sudden when i try and send a message its says. “cannot send message using the server smtp.mac.com:username.
    I only have 3 choices and none of them work please help.

      Nick
      8/1/12 @ 8:32 pm

      Plus I’m not even running a server or have nothing a my computer related to a server

        8/2/12 @ 8:13 am

        By “Server” it is referring to your Mail server. For instance, if you use Gmail, then you’d be connecting to Google’s Gmail server to receive and send email. If you use iCloud email (@me.com, @mac.com), you’d be connecting to Apple’s email server.
        If this case your email client, Mail, is trying to connect to the server located at smtp.mac.com and not being able to. It could be a temporary problem. Or, if could be a problem with your settings — trying to use Apple’s email server to send email even though you are using Gmail as your email server, for instance.
        I’d have a computer-savy friend (or local shop, or the Apple Store Genius Bar) take a look at your email settings to make sure you are using the right servers.

    Lisa
    10/23/12 @ 5:11 pm

    The server returned the error: The connection to the server “mail.comcast.net” on port 995 timed out.

    I’m not sure what these means? But I am not getting any emails. Any help?

      10/23/12 @ 5:25 pm

      It just means that you couldn’t connect to your ISP’s mail server. Wait and try again later. If it still doesn’t work then call their support. Your setting may be outdated and they can walk you through that. Or, they may be having a serious problem.

    Lisa
    10/24/12 @ 8:45 am

    So my ISP provider (comcast) is telling me the problem is with Router (Cisco) E4200 after we connect the modem up to the desktop. The router company tells me that they have upgraded all of the information with remote access from my computer. Now the router company tells me that I have to update the receiver on the iMac desktop. Does this sound right to you? If so, how do I update the receiver on the iMac? Everything else is working just great on the iMac with the Internet connection. The only problem is the apple mail shows that it is off line and cannot receive emails. But my iphone 4s still is receiving email like normal.

      10/24/12 @ 8:49 am

      “update the receiver on the iMac” — that doesn’t make any sense, no. I think you might need first-hand help to get this resolved. It doesn’t make sense that your router would be the cause. If you can surf the Internet then you are connected. It is doubtful that your router would be allowing you to surf the net but not get email. I’d call Comcast back and have them walk you through your email settings.

Comments Closed.