Forum Question: Mail not getting new mail from gmail

Hi Gary,

Since yesterday my Mail application is working fine for composing and sending emails but it is not refreshing the inbox, despite repeatedly clicking ‘Get New Mail’ I tried everything the Mail Help suggested but no luck. Gmail option is grayed out in the get new mail tab and also in the Gmail tab in the sidebar. Any help would be appreciated.


— Ank

Comments: 6 Responses to “Mail not getting new mail from gmail”

    6/22/10 @ 9:06 am

    Nothing to do but to re-enter your gmail id, password and other settings. Are you using IMAP or POP? If IMAP, then you can always try deleting and re-creating the account.
    Have you installed anything recently that may be blocking ports (a firewall or anti-malware product?)

    6/22/10 @ 10:15 am

    If you didn’t change anything in Gmail, then it’s setup as POP3.
    Snow Leopard has a few issues with POP3 Gmail.

    You need to do the following to resolve this problem:

    1. Open
    2. Go to Preferences
    3. Click on the Accounts Tab.
    4.Go to the Advanced Tab
    5. Make sure that the “Port” is set to 995 (Using SSL).
    Port: 993 is for IMAP.

    After you have done this and you’re still having problems with receiving e-mail, then you should delete your account, set it up again and during the setup you need to make sure that the user account is the same for incoming messages and outgoing messages (e.g. isn’t the same as example).

    If it’s still not working then I suggest you use IMAP:
    Login to, go to settings, and where it says: Forward POP/IMAP. Turn POP off and IMAP on.
    Then set up your account again in and it will do it correctly.

    Good luck.

    6/22/10 @ 10:29 am

    Hi guys,

    The port was set at 993….I changed to 995 and re-tried…it gave a pop up messgae saying that the imap certificate was invalid and it could be another server pretending to be imap. I think I’ll reset everything, though Good knows how this happened…reminds me bitterly of my Windows days when I couldn’t understand why crazy stuff happened all over the machine.
    Thanks for the inputs, both!

    6/22/10 @ 10:58 am

    IMAP uses 993, not 995.

    Again, make sure that if you have to enter something manually, that the usernames are the same.

    Let us know if you fixed it and how you did it.

    6/22/10 @ 8:11 pm

    Hey guys,

    I had to delete and re-configure it again. It automatically set it to imap. it’s up and running now!

    6/23/10 @ 3:15 am


Comments Closed.