Forum Question: No audio when connecting iMac to LED TV

I connected a ‘Mini displayport to DVI adapter’ with an ‘HDMI to DVI digital Video Cable’ from my iMac to an LED TV. THe picture is there but no sound. The only output device recognised in the systems preference is the built-in internal speakers.
—–
Lara

Comments: 4 Responses to “No audio when connecting iMac to LED TV”

    1/5/11 @ 2:38 pm

    It sounds like the HDMI adapter doesn’t convey sound. Some don’t. Or, more likely, the Mini DisplayPort to DVI adapter doesn’t convey sound, so the HDMI adapter doesn’t have any sound to convey. That’s more likely, actually.

    Marcel Testaert
    7/26/11 @ 2:00 pm

    Gary watt you said to Lara is absolutely correct. I have Apple tv 1st gen that is connected to a Philips TV from HDMI to DVI (TV side) and I had to use the red and white soundconnection (out on the appletV side ) to the red and white inputs on the tv and that works quite well. I

    Chris
    12/23/11 @ 8:29 am

    I have tried connecting my iMac to my LCD TV, through dvi to hdmi. I can get the systems to mirror each other but can get no sounds? However I connect my Macbook pro using the same cable and did get sound? any idea if there is different settings?

      12/23/11 @ 8:59 am

      Is it exactly the same cable? If it is DVI to HDMI then there would be no sound on either. DVI does not carry sound. Mini DisplayPort can carry sound, though. Maybe that is what you are using. Otherwise, check your sound preferences to make sure that the right device is selected for sound output.

Comments Closed.