Forum Question: Pages and languages dictionary

Greetings…. a perplexing and irritating problem with the languages dictionary. I work with text in two languages and when I choose the second (French), Pages insists on reverting to the first (British English).

I have already tried to reset system preferences language and input sources without any luck.

At the moment my best solution has been to copy and paste into a Mail document which has no language hangups!

Any suggestions would be welcome!

Many thanks.
—–
Ray Alston

Comments: One Response to “Pages and languages dictionary”

    10/22/10 @ 6:39 am

    Here’s how you do it.
    First, open the Inspector (View, Show Inspector if it is not already there).
    Then, go to the Text tab (Letter T as the icon at the top).
    Next, click on the “More” section in there (you have Text, List, Tabs, More).
    Under Language, switch to Francais.
    This changes the language setting for the text selected and any text you type from the cursor — just like selecting Bold would make any text selected bold, or any text you typed at the moment. So if you have text already in your document, you must select it first before changing it to French.
    What this means is that you can have multiple languages in your document. You can select some and make it French, make other parts English, etc. For instance, you can have an English document with a French quotation in there and select the quote and change it to French so the spell checker recognizes it. Cool!
    One thing: I’ve noticed that if you have a new document (not saved yet) that the spell checker won’t notice the language change right away. You need to save the document first.

Comments Closed.