Forum Question: Reinstalling OS X Lion To Solve Sleep Problem On MBP

Gary, I am not completely sure of the process to reinstall OS X Lion. I have been having a problem with my MBP going to sleep mode (won’t do it by command or lid closing). I can shut down and all apps seem to work fine. The only big deal I did recently was to test a clone copy just to see how the process worked (my first attempt). That went OK, albeit slow. After the start from the external clone copy, I used some apps and seemed OK. I shut down and restarted with the OS on my hard drive. It was after this process I first experienced the sleep problems.
I want to try to reinstall OS Lion to see if that would make a difference. I have a MBP which had Snow Leopard and have a USB drive Lion upgrade from Apple Store.
I also use a Time Machine with a Time Capsule.
Is the reinstall process straightforward?
—–
Michael Wheless

Comments: 2 Responses to “Reinstalling OS X Lion To Solve Sleep Problem On MBP”

    12/10/11 @ 10:40 am

    The re-install process depends on a few things. But for most, it is a matter of starting up using the Recovery/Restore partition. So restart your Mac and hold down the Option key to get a choice of which partition to boot from. Choose the Recovery partition.
    Then you get several options, one of which is to re-install Lion. You go from there. You don’t want to erase your drive, of course, you just want to re-install Lion.

    Michael Wheless
    12/18/11 @ 12:49 am

    Gary, I want to pass along the manner in which I resolved (I hope permanently) the sleep problem I was having. I did not want to mess with my Lion install unless it was absolutely necessary. So, I continued researching and viewed many of your Lion instructions repeatedly.

    What I found as a solution was to look at my printer queue. I had upgraded the Canon printer software and in that process, it left behind the older driver and icon in preferences. At some point in recent weeks, I had attempted a print job and it failed. I figured out to switch to the newer driver (different icon in preferences) and the print job succeeded. However, I never emptied the queue for the older icon.

    I simply emptied the queue of old print jobs and problem was solved. Sleeps normally.

Comments Closed.