Forum Question: Restoring Address Book data

I’ve got a good one here. Somehow, my address book data has been corrupted and I cannot restore a backup to it. Still not sure how the data was corrupted, but the only way I noticed it was when I went to it on the iPhone, nothing there. I’ve got backups from time machine, but the computer will not let me replace Address Book. I get a message that MAC OS X needs address book. I’ve got Lion, and the iTunes setup was modified also. Can you or any of your readers provide any help on this matter? Sure would like to get my address book back to a usable state. Thanks!
George Kahler

Comments: 11 Responses to “Restoring Address Book data”

    9/16/11 @ 6:48 pm

    Are you trying to replace Address Book, the Application?
    Data, like addresses and contacts, are not stored IN the application. They are usually stored in your user folder somewhere, in data files. In this case in ~/Library/Application Support/AddressBook/
    See if you can restore that folder from your backup.

    9/16/11 @ 7:44 pm

    Hi – looked in the place you suggested, but there is no AddressBook in Application Support. Could that be the problem? I’ve went back to Sept 1st. What else could I try? Thanks!

      9/17/11 @ 9:35 am

      Make sure you are looking in the right place – the Library folder in your user folder, not the Library folder at the system level.

    9/17/11 @ 10:47 am

    Gary – I must not understand the system very well. When I go into Finder, then the System (computer) folder and then into the user folder, there is no Library folder in my user folder. Nor is there one in my named user folder on the Sidebar (left) side of finder. Am I supposed to get to the user folder another way? User sub-folders has things like; desktop, downloads, document, music, movies, etc. Don’t give up on me, would very much like to get my address book data restored…

      9/17/11 @ 10:51 am

      In the Finder user the Go menu. Hold down the option key and choose Go, Library (Library doesn’t appear until you hold down the option key).

    9/17/11 @ 12:39 pm

    Gary – yes, using your last direction I found the file. Now, is there a similar one in the backup set, and if so, how do I go about finding it? I tried the same procedure but there wasn’t one there. Also, tried the last instruction but there isn’t the Go command in the backup set.

      9/17/11 @ 12:42 pm

      With the AddressBook folder open, enter Time Machine. If it doesn’t show a folder, then use the control on the right to go “back in time” until it does.
      If that doesn’t work, i think at this point you may want to consult an expert (Genius Bar, local shop, etc).
      Or, you could always just start a fresh new Address Book if that is easier. Maybe use Google or MobileMe (if you have it) instead of storing it locally on your computer.

    9/17/11 @ 2:10 pm

    One last question. I’ve got the time machine open to the AddressBook folder as you directed; now, which sub-folders need to be copied? There is 5 folders other than the app itself.
    Gary – thanks in advance for all your help and patience. (Hoping this works :-)

      9/17/11 @ 3:31 pm

      I would just restore the entire AddressBook folder. See if it works.

    9/17/11 @ 4:59 pm

    That seem to work. One file would not update, it said I did not have high enough/ proper access to it. Not sure which one it was, but the info for address book is back. Again, thanks for your help!!

    12/3/12 @ 3:12 am

    Hi Gary, George,
    I had exactly the same problem but you solution worked brilliantly, Gary. Thanks a bundle!

Comments Closed.