Forum Question: sync iphone with mac or mobileme?

I have an iPhone 3G and recently updated to OS4. I have synced my iphone with my Mac through iTunes for the last 2 years, it worked beautifully. But now the first sync I did with iTunes (after update) it duplicated all my calendar events and gave me 2 different groups in my contacts. I had to contact MobileMe to assist me in fixing this problem. They solved my problem and told me to only sync with MobileMe and turn off contacts and calendar on my iTunes (I always had them on). Could someone explain what happened? I always thought that I could sync with iTunes maybe once every 2 weeks and MobileMe would do it automatically everyday. Thanks

— Ellen Artigas

Comments: 6 Responses to “sync iphone with mac or mobileme?”

    7/1/10 @ 9:53 pm

    If you have MobileMe syncing, then there is no need to sync contacts and calendars with iTunes. Doing so would give you a second set of everything. Just turn off the iTunes sync for those items, and let them sync over MobileMe. Sounds like you already have done that, so you should be all set.
    You would think that the system would be smart enough to realize that the contacts and calendar events were the same, but it doesn’t. So if you ask it to sync from two sources, it does what you ask, and you end up with two sets of data.

      Ellen Artigas
      7/2/10 @ 9:10 am

      Thanks “Mr. MacMost” I really appreciate your news letters

    9/14/10 @ 7:04 am

    On the iTunes info tab when my iPhone is attached all my checkboxes are off and I’m synching with mobile me. I still have two sets of data on my iPhone for contacts and calendar. Due to some monumental mistakes I would love to know how to completely erase my “all on my iPhone” contacts and calendar. Any help would be appreciated.

      9/14/10 @ 8:29 am

      You’re going to have to work at it. Stop syncing to MobileMe (temporarily) and then sync your calendars via iTunes. Then unsync them. Try a few times with different settings until your contacts and calendar are empty on the iPhone. Then re-setup MobileMe syncing.

        9/23/10 @ 9:54 am

        Thanks Gary, I’ll get on it.

    9/28/10 @ 8:02 am

    Gary, you da man! Worked like a charm, albeit a slow one due to my lack of computer savvy!

    Thanks again for the advice, site, podcasts etc.

Comments Closed.