Forum Question: Time Zone weirdness in iCal and MobileMe

When I download a calendar event from the web, (e.g. “Add to my Calendar”), it enters as UTC time. I have time zone support on in iCal and I have selected my local time in MobileMe, so in month view it shows my time zone as it’s supposed to, but when I double click a downloaded event for more detail the time is in UTC?? And when I select my local time it won’t auto adjust to my time zone. BUT when I select “floating” as the time zone, sometimes it does automatically adjust to my time zone!
What is the “floating” time zone, and how to I get Cal events that I download (“Add to my calendar”) to iCal to come in on my local time zone?
—–
Royce

Comments: 3 Responses to “Time Zone weirdness in iCal and MobileMe”

    1/9/11 @ 3:30 pm

    I’m not sure. I don’t receive calendar events from others, so I’ve never experienced it.
    As I understand it, floating times will not change to adjust to local time zones.
    I searched and found this article at another site that may help:
    http://www.macobserver.com/tmo/article/Understanding_iCal_Time_Zones/

    Royce
    1/11/11 @ 3:07 pm

    Read the link you sent me. Wow, definitely weird since according to article “floating” shouldn’t change the time but for me it did. Also, never had the time zone issue before, only when after updating to 10.6.6 did my downloaded events go to UTC. In the past when, before 10.6.6, Cal events would download to to my time zone. I wonder if this is MobileMe issue, and not because of 10.6.6

    Sue Ryan
    9/1/11 @ 9:35 am

    The turn on time zone support is something that really causes more issues than it helps with since it is so easy to get our calendars accidentally set to the incorrect time for appointments. Be very careful with it. I did some testing on my test user, and it doesn’t do what it sounds like it would do.

    Invitations also don’t convert to the different timezones. I need to invite people to a teleconference and they are in four different timezones. It requires them to convert. If you know a workaround, I’m all ears!

Comments Closed.