Forum Question: Troubles with a flash drive

I recently had troubles with my flash drive (Lexar 4GB). The computer said I didn’t have the proper ‘permissions’ to access a file, so I tried to delete it. However, it wouldn’t let me delete the file either. So I ran disk utility and I reformatted the flash drive to erase it completely and start fresh. When I reformatted it, I formatted it for MS-DOS (FAT) so that I could use it with my computer and the pc computers on campus. When I tried to use it on a pc, I got a message that said it had to be reformatted. I ran disk utility on my mac, and it showed that it was formatted for Mac OS Journal (extended). I tried formatting it again as MS-DOS (FAT) but it still formatted it as Mac OS Journaled (extended). I looked my situation up on the internet, but it was of no use.
Do you have any suggestions for me? It is formatted as Mac OS Journal (extended) so I can still use it on my mac and any campus macs, but most computers on campus are pc, so I would like to be able to use them out of convenience.
—–
matt

Comments: 2 Responses to “Troubles with a flash drive”

    11/1/10 @ 8:33 am

    I’ve never run into that. Perhaps you weren’t selecting the format quite right, or following through on re-formatting it completely. Hard to say without being there.
    But one option is to simply reformat it on one of the PCs you use.

    Matt
    11/1/10 @ 1:37 pm

    I am pretty sure that I did everything correct. It is not that hard of a task. I managed to reformat it on a pc, and so everything is fine now, but I am still curious as to why it would not reformat correctly on my mac. The computer insisted on formatting it as a Mac OS Journal (extended).

Comments Closed.