MacMost Q&A Forum • View All Forum QuestionsAsk a Question

Why Doesn’t the Filter Option In Numbers Show Everything?

So I’m using Numbers v3.2.2 on Mavericks (10.9.5).
The issue I’m having is – when I select the Filter Table option under a particular column, it is not showing all of the filter options that are actually in the cells of that column.
It’s a light data spreadsheet I’m creating for songs that has a few columns of information. I have a column titled BPMs (beats per minute) where the numbers vary in range as the spreadsheets develop. Well, when I go to this column and select the Filter Table option, only some of the numbers show up.
I feel like I’ve tried everything. I’ve tinkered w/ the Cell’s ‘Data Format’ option trying various option too see if the missing by numbers would populate. I’ve tried deleting the numbers and retyping them. I’ve tried ‘Add Row Below” and pasting the numbers in. Still nothing.
I’m really stumped at this point!
Any assistance is much appreciated.
Michael Henry

Comments: 3 Responses to “Why Doesn’t the Filter Option In Numbers Show Everything?”

    4 years ago

    I’m confused as to what you mean by “only some of the numbers show up.” Numbers don’t “show up” — you type them in.
    So I have a column that has values like 90, 120, 140, 160, etc. I choose Sort & Filter on the right. Then I click on Filter. Then I click Add a Filter. I choose the column. Then I choose a rule. The options are Numbers, Text, Dates, Durations, Blank. I choose Numbers. Then “Number is equal to.” Then I type in the number 120. There is nothing to “choose” I have to type in that numbers.
    Now I see only the rows that have the value 120 in that column.
    So what are you doing differently? Describe it like I am describing my actions above.

    4 years ago

    I’ve actually been filtering another way, as seen in one of your videos on this topic. I go to the header of the column and from the drop down menu I select ‘Filter Table’. When I select this option a menu is revealed showing the data in that respective column. However, it’s not showing all the data that’s been input into that column; so I’m not able to effectively filter b/c I’m not seeing all the data for that column. Make sense? Thanks.

    4 years ago

    So, try it the way I outline above. See if that works for you.

Comments Closed.