Forum Question: Desktop Icon Problems

I recently upgraded my RAM on my iMac G5(no camera), running OS 10.4, to 2gigs. Now, whenever i click on any of the icons on my dock that are located on my external hardrive, a whole new icon appears on the right side of the dock and starts bouncing. The icon that i originally clicked on does nothing. So it is like the wrong app opened. If there is anything you can think of to help me please tell me what it is. Thanks.

— Dylan

Comments: 5 Responses to “Desktop Icon Problems”

    2/6/10 @ 3:08 pm

    You said “the wrong app opened” — do you, in fact, have two copies of those apps? If so, which one opens and which one SHOULD open. Did you try to replace those Dock icons with the applications you want to use?

      Dylan
      2/6/10 @ 4:07 pm

      I should have said it was “like” another app opened. I only have one copy of the apps on my external hardrive. When i click on the icon, the correct app opens, but it opens as a whole different icon on the right. I have already tried replacing the broken icons with the ones that open on the right but it just reset itself when i restarted my computer.

      Here is the best image i could make. I click on the one on the left and an icon for the same app starts bouncing on the right.

      Icon——————————->Icon |Trash
      ^

        Dylan
        2/6/10 @ 4:08 pm

        The little arrow on the bottom was supposed to be under the icon on the right.

          2/6/10 @ 4:15 pm

          I have one guess. Perhaps it has to do with permissions. Something like the apps don’t have quite the right permissions set, since they are on an external drive like you said. Try playing around with that.

            Dylan
            2/6/10 @ 4:35 pm

            I tried and they all said I could read and write, but there wasn’t any options even grayed out ones that aren’t clickable. When I opened an app on the internal hardrive, It said i could read and write also, but it had a details triangle and all the options were in those boxes with that looked like they cold be changed, even if they were grayed out. I am also the only one using this computer and am definitely the administrator.

            Thank You anyway

Comments Closed.