MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Change the Preference In Mac Mail To Allow “View In Place?”

A few months ago while running High Sierra, I changed my Mac Mail preferences using a Terminal command so that mail would always show attachments as “Icons.” Through the termninal command — defaults write com.apple.mail DisableInlineAttachmentViewing -bool yes — the “View in Place” option was eliminated. Today I went back to change the terminal command back to allow “View in Place” and for some reason the command — defaults write com.apple.mail DisableInlineAttachmentViewing -bool no — will not work.

Does this have somehting to do with the upgrade to Mojave? And, would anyone please be able to help me change this Mail feature back?
—–
JimEmmons

Comments: One Response to “How Do I Change the Preference In Mac Mail To Allow “View In Place?””

    7 months ago

    I don’t think DisableInlineAttachmentViewing has worked in Mail for several versions of macOS. So yes or no won’t make any difference.

    Attachments in email messages are tricky. They mostly rely on the message itself. For instance, you could have a message that is composed with HTML (rich text) and have images in that HTML. Those images can be encoded into the message, or located on a remote server. They can also be in Apple’s MailDrop.

    But you can also have non-HTML (plain text) email that has files attached. There are so many different ways to format an email and send it, and then have your mail client, Apple Mail in this case, interpret the message and display it. Sometimes, I think, Mail will display small images as themselves, but if the image is too big it shows as an icon. Sometimes if the file is coming from a server (not encoded) it appears as an icon first, and is then shown when it is fully downloaded.

    If you are seeing an attachment as an icon in a message, it could be because that is how the file is supposed to appear according to how the email was created. And there is no setting to change that because it wasn’t decided on your end.

    The only setting in Mail that I know of that changes something like this is Mail, Preferences, Viewing, Load Remote Content In Messages. So check that.

    There could be a setting with your email provider too. They may have something on their server (web interface) that allows you to change how email gets through to you. But that is likely more about sending email than receiving it.

    But most likely you are not seeing a change when you use that Terminal command because it hasn’t been working in the first place. I checked my email just now and I see a variety of things: some messages with attachments as icons, some inline, some being used to nicely format the email, etc. In one case an email from a large corporation had the images inline and then they appeared at the end too.

Comments Closed.