MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Populate iMessage Conversations On iMac From iPhone?

Upgraded iMac to 10.14.3 this morning. All went well but iMessage has not repopulated from my iPhone 6 (12.1.4). I can start & send new messages, but the conversations on my phone haven’t transferred to the iMac. I tried signing out of my iCloud account on both iPhone & iMac & signing in again. I also restarted the iMac. What am I missing?

Thank you,
—–
Sherry Missig

Comments: 4 Responses to “How Do I Populate iMessage Conversations On iMac From iPhone?”

    7 months ago

    First, make sure you have enabled Messages in iCloud on both devices. On your iPhone, go to Settings, your Apple ID at the top, iCloud, and then look for Messages and make sure it is turned on.

    On the Mac it is Messages, Preferences, iMessage, Settings. There is a checkbox for Enable Messages in iCloud. Then next to that is a Sync Now button you can try.

    If that doesn’t work, I find that simply adding a new message to the conversation from your Mac will make the conversation appear. So if you have a conversation where you are texting person A, then just compose a new message to A on your Mac and a new conversation appears between you and A, and the old messages arrive into the conversation after a minute.

    One note: If you are talking about SMS text messages (mobile phone messages, not Apple’s iMessage system) then you need to enable the Text Message Forwarding option. On your iPhone, go to Settings, Messages, Text Message Forwarding and turn it on for your Mac.

    Sherry Missig
    7 months ago

    Settings on iPhone & iMac are enabled. There is not a Sync Now button on the Messages preferences settings page. For a time I had a message on my iPhone saying Messages was uploading to iCloud but it’s gone & nothing has changed. I initiated new conversations from the Mac, but still no old messages. Maybe they will appear at some point?

    Thank you for your quick response.
    Sherry

    7 months ago

    Sherry: Not sure why you aren’t seeing that button. At this point I would call Apple support and have them check on this for you.

    flo
    6 months ago

    I had the same issue, after my MBP was offline for a while. Found this:
    https://discussions.apple.com/thread/8411068
    Now I got the Enable Messages in iCloud checkbox back and the button Sync now. No idea if that works. I hope it is syncing while I am typing :D

Comments Closed.