Forum Question: OSx Lion fix – Volume, keyboard & Screen brightness keys.

After much frustration and reading about this problem (resetting PRAM, scripts, etc.) It just ain’t that hard. Just uncheck the “Use F1, F2, etc…” checkbox in the keyboard system preferences. The labels for all of your function keys will work like they used to. I can’t say how this will affect other functions though. It may just depend on what’s more important to you.
On a side note, I really like hearing great ideas and fixes from the rest of you, but no one cares if your in the middle of downloading your new OS – post that crap on FaceBook, that’s what it’s for. I think we’d all appreciate less meaningless content.
—–
Sean-

Comments: 9 Responses to “OSx Lion fix – Volume, keyboard & Screen brightness keys.”

    7/22/11 @ 10:38 am

    People are actually suggesting resetting PRAM for this? This non-issue has been around for many versions of OS X. Can’t believe that people still are getting caught off-guard and trying crazy things.

      Sean-
      7/22/11 @ 11:07 am

      I actually got bought up in that and nothing worked. I didn’t figure the folks building Lion would overlook something like that so I figured it had to be simple. People have a tendency to over complicate things and it has gotten WAY out of hand in the past 10-15 years. I wish people would/could look back at what technology was /supposed/ to do – make life easier not make people pull their hair out (they have puzzles and jobs for that).

        Sean-
        7/22/11 @ 11:12 am

        Sorry, “caught”, I didn’t buy anything. I’m new to Mac and am VERY happy about it. Why are people trying to turn me into a computer geek?! That’s not what I do, no wonder so many people hate their IT department.

        Dl Betty
        8/19/11 @ 10:10 am

        YES EXACTLY!

    Oli
    7/25/11 @ 2:24 pm

    You’re the first person I’ve come across who seems to understand this problem (which I share).

    However, my Keyboard Preferences in the System preferences doesn’t have that option!

    This is doing my head in – I’ve had Macs for 15 years and this is surely a bug, as I can’t see any way of getting it working again…but if you know different, please let me know!

    7/25/11 @ 3:28 pm

    Which OS are you using (Snow Leopard, Lion?) And which keyboard are you using?
    It is definitely there, if you go to System Preferences, Keyboard, then the Keyboard pane (not the Keyboard Shortcuts pane) and look for “Use all F1, F2, etc. keys as standard function keys.”
    That simply toggles how those keys and the “fn” key work. Using the “fn” key switches them temporarily.

      Cody
      7/27/11 @ 10:52 am

      There is no option for “Use all F1 . . . ” in the keyboard options in Lion that I can find. I had this problem the first time I got a new keyboard and originally that fixed it. However, it no longer seems to exist. I am under the keyboard pane and not the keyboard shortcuts. Anyone find a solution yet?

        7/27/11 @ 11:16 am

        Perhaps it is your keyboard. Which one do you have? Is there an fn key? Perhaps you have set the keyboard to be something else? Check in the Language & Text preferences, Input Sources.

    fak3r
    7/30/11 @ 7:16 pm

    Thanks, this happened to me and I could not figure it out, but now that I’ve re-read the bit by the checkbox you point out, it makes sense.

Comments Closed.