Forum Question: Sorting ascending or descending in Finder in Lion

I’m reading everything about Lion, but I can’t find out how to sort files in Finder in ascending or descending order. I can’t click the column header. Thanks.
—–
Russell Winkler

Comments: 40 Responses to “Sorting ascending or descending in Finder in Lion”

    7/21/11 @ 7:57 pm

    That hasn’t changed. You click on the column headers as before. Are you sure you are in list view, not column view?

    Russ
    7/21/11 @ 8:13 pm

    I have it in List VIew and Arrange By: Kind (and Application) and i was hoping it would allow me to sort ascending or descending in each group, but it didn’t seem to do that. In List view and Arrange By: None, I can click the titlebar to sort like you said.

    Bryan Maniotakis
    7/21/11 @ 9:34 pm

    I’m having the same problem. My co-worker just updated and his is working fine.

    Susan Wong
    7/28/11 @ 12:30 am

    Same problem here.
    Some list view windows have the traditional grey bar that i can click on a column and it goes blue and sorts.
    Other list view windows have a new white bar (the same as the all my files header) that won’t let me sort no matter what i click on.

      An Tran
      12/30/11 @ 6:12 pm

      It is the same for me. The header becomes white, not grey like before but just for Downloads folder. I cannot click on it to sort or to resize the columns.

    Paul
    7/30/11 @ 1:45 pm

    This was the latest in a growing list of UI tweaks that Apple have made in Lion that were driving me insane, resulting in me looking for the option to make it work the old way.

    In list view, you have to set ‘arrange by’ to ‘none’ from the rightmost icon in the toolbar, then you get the usable stuff back.

      Robin
      8/22/11 @ 8:09 pm

      Thank you, Paul. This is what I was looking for.

      Tim
      10/7/11 @ 2:40 am

      Great answer…it’s been driving me mad!
      New question, Paul, I want to see the files I’ve opened today in Finder..is that possible?

      FUIceman
      12/12/11 @ 9:10 am

      Thank you, Paul. I was getting seriously frustrated about that exact issue.

      An Tran
      12/30/11 @ 6:14 pm

      Cool! Thanks for much, Paul. It works fine.

      Marc
      4/3/12 @ 5:24 am

      Thank god for that! We’re in a design studio and all the folders are numbered so it was showing the most recent at the bottom!

      Thanks for the fix – we can go back to working instead of scrolling now :)

      bob
      4/16/12 @ 2:21 pm

      thanks Paul. It worked fine.

      seanylala
      5/1/12 @ 4:17 am

      Great and useful answer Paul. This worked. How annoying that it required a search. To Apple: “If it ain’t broke, don’t fix it”

      Justin Long
      6/15/12 @ 1:53 pm

      Just found this by Google search. Glad you kept me from going insane. Thanks.

      Brian
      12/4/12 @ 11:06 pm

      Thank you! How did you figure this out?!

      Sarah Talmi
      1/7/13 @ 12:34 pm

      Thank you Paul!

      It does get frustrating when they don’t notify you of these changes and do not list in “help” or anywhere how to do things.

      john
      2/7/13 @ 9:49 pm

      Great – thanks for the good tip, Paul!

    DAZ
    8/2/11 @ 6:02 pm

    You are right, in list view you can arrange by name, BUT I use column view. In column view I can no longer sort by name, no matter what I do. I would have thought this would have been one of the most important tasks of ‘finder’. They should change the name of ‘finder’ to ‘loser’ because it is now much harder to find what you want. I can’t believe they have made this mistake, or is it me, am I going crazy here?

      8/2/11 @ 6:08 pm

      I’m not sure what you are referring to. In Column view in the Finder (I prefer Column view) sorting by name is the only option. Well, I can “arrange by” something else, but that is strictly optional.
      If it is not sorting by name for you in Column View, then what is it sorting by?

        DAZ
        8/3/11 @ 5:28 pm

        It appears to be arranging by date created, but not sure. It almost appears random. This only started when I updated to Lion. I tried selecting ‘none’ in ‘arrange by’ and this made no change at all. Is anyone else out there on Lion getting this? Am I cursed? As well, when I used to send emails I could attach a file by selecting it from recently opened in the left hand column, which was great. Often a file to send was one I had just used. Now this has been removed from the view. Any help greatly appreciated.

          8/3/11 @ 5:37 pm

          Try different views. Different folders. Experiment. I can’t imagine what would cause this.

            DAZ
            8/3/11 @ 7:18 pm

            Hi all. Sorted. Mac is cool again. I rang the help line.
            Searching through finder I was instructed to drag a small ‘finder’ file from one of the finder programmes onto the desktop.
            Restarted the Mac, which then re-generated this defective script and it fixed the issue immediately.
            Thank god. I was ripping out my hair over this.
            Thanks for trying to help and good luck to you all.

      Dave
      10/24/11 @ 10:03 am

      So true. The Lion Finder is completely and totally insane!

    Michael
    8/2/11 @ 7:51 pm

    Click on arrange button in toolbar (far rights icon) and select none. The clickable headers will be restored

      DAZ
      8/3/11 @ 6:50 pm

      Tried this with no change.

      Kate
      11/3/11 @ 8:53 am

      This totally worked for me – it was exactly what I’ve been looking for!! I’ve been getting so frustrated because somehow my files were sorted Z – A and I couldn’t figure out how to change it back to A – Z.

      With Michael’s help my summary of how to customise “List View” is as follows: when using “List View” selecting Arrange By > Name will give you the floating white headers that you cannot click on, but Arrange By > None will give you solid grey headers that you can click to toggle between ascending and descending and which will also allow you to edit the width of your columns (not to be confused with “Column View” though!). When you have Arrange By set to None you can use the Sort By > Name function from the View Options menu to keep you files in alphabetical order.

      I hope this helps somebody else like me to figure out the new ins and outs of Lion – Good Luck!

        gina
        2/6/13 @ 10:37 pm

        Thanks
        Awesome answer! Finally fixed mine

    DQ
    8/4/11 @ 11:32 am

    In column view. Go to View->Show View Options or press Command-J.

    Select Arrange by Kind and Sort by Name. On mine it was originally set to sort by Date.

      Chris
      3/9/12 @ 1:04 am

      Thank you DQ, I couldn’t work this out but Command J solved it beautifully!

    Patrick
    8/14/11 @ 7:07 am

    Same issue here – sort doesn’t work. The only “sort” that kind of works is “None”. I’m not enjoying my Lion experience for all sorts of other reasons too. Put me down as voting “fail”.

      8/14/11 @ 7:09 am

      I think you are confusing Sort with “Arrange By.” See episode 588: http://macmost.com/arranging-files-in-lion.html
      If you are looking to sort the files in a folder, you need to set “Arrange By” to None and then you can sort. You simply don’t want to use the “Arrange By” feature — then you get to sort like Snow Leopard.

    Patrick
    8/15/11 @ 12:24 pm

    Chr*st, I have to watch a six minute video of a bearded man in a tie-die T-shirt in order to understand how to arrange my files? Thanks for the link Gary, at least I know how to do it now, albeit that I have no idea WHY Apple have done this.

      Patrick
      8/15/11 @ 12:33 pm

      Not that there is anything wrong with tie-die or beards of course – I’m a bit of a hippy at heart myself!

        8/15/11 @ 1:30 pm

        I’m not even a hippy at heart. My wife just likes me with a beard, and my daughter made the shirt for me. :)

    Evan Mitchell Stark PHd
    8/20/11 @ 8:50 am

    In Lion, with my dock Applications folder set to List view, how can I get it to display beginning with applications that start with “A” instead of with “S,” i.e, ascending order?

    Thanks!

      8/20/11 @ 9:07 am

      Click on it and select the Options choice at the bottom. There you can set the sort order.

    Sharan
    9/3/11 @ 1:03 pm

    Hey i am arranging the folders in finder by kind…But its frowning them…how do i undo that grouping stuff….I want only view by kind..

    Cindy
    9/11/12 @ 5:22 pm

    Paul you are brilliant! Thank you so much for taking the time to share this information. I want to display my folders A-Z in descending order like normal – not with the Z at the top and the A at the bottom. Your solution works a treat.

    Chrizty
    1/11/13 @ 1:15 pm

    Great comments!! Very helpful! Thanks everybody!! :D

Comments Closed.