MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Delete Same Email On All Devices?

Using iCloud Mail, I receive the same emails on my iMac, iPhone and iPad. But can’t I sync deleting them? When I delete on my iPad, the same email remains on the other devices. Why isn’t it removed on all?
—–
Stan Greenberg

Comments: One Response to “How Do I Delete Same Email On All Devices?”

    4 weeks ago

    It should. But it depends on which email service you are using. If you are using modern email (IMAP/Gmail/iCloud) then your Mail apps on your devices are showing you a reflection of what is on the server. If you delete a message, it deletes it on the server and all of your devices should update to show what the server has.

    However, if you are using older email, like POP or ISP email, then you won’t see that as all Mail apps will download all email separately and manage them as files on the local drive, independent of the server.

    So when you say you are using iCloud mail, are you using an iCloud.com, Mac.com or Me.com email address? If so, then you should see the email delete across your devices as the iCloud server is updated. But if you mean you are using iCloud to simply sync your settings, and actually using another email service, then you may see each Mail app acting independently.

    So if you are using iCloud’s email servers, I’m not sure why you aren’t seeing the email delete. Maybe check your settings on the various devices to see if you see anything unusual. For instance, in Mail on Mac, look in Preferences, Accounts, (Account), Mailbox Behaviors. Maybe you have your Trash Mailbox set to something other than the iCloud Deleted Messages folder?

    Or, maybe this is a matter of things just syncing slowly? After a few minutes do the other Mail apps catch up? Or, maybe they are set not to check for updates until you do so manually?

Leave a New Comment Related to "How Do I Delete Same Email On All Devices?"

:
:
:
0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)